diff mbox series

[bug#73433] gnu: fetchmail: Wrap fetchmailconf.

Message ID 7a846ae9ae2d5e39baac76f847e51fbadefa59b4.1727074920.git.efraim@flashner.co.il
State New
Headers show
Series [bug#73433] gnu: fetchmail: Wrap fetchmailconf. | expand

Commit Message

Efraim Flashner Sept. 23, 2024, 7:03 a.m. UTC
* gnu/packages/mail.scm (fetchmail)[arguments]: Add a phase to wrap
fetchmailconf with GUIX_PYTHONPATH.
[inputs]: Add bash-minimal, python-future, python-wrapper.

Change-Id: I6f48361e7d739bfcaa2d1f20eb177933e5e7a5d8
---
 gnu/packages/mail.scm | 15 +++++++++++++--
 1 file changed, 13 insertions(+), 2 deletions(-)


base-commit: 41e408eb1f93d96b549d345e2de74143220b7b76

Comments

Efraim Flashner Sept. 29, 2024, 4:11 p.m. UTC | #1
Patch pushed
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 52ac86dfbda..e4316831d03 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -633,9 +633,20 @@  (define-public fetchmail
     (arguments
      (list #:configure-flags
            #~(list (string-append "--with-ssl="
-                                  #$(this-package-input "openssl")))))
+                                  #$(this-package-input "openssl")))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'wrap-fetchmailconf
+                 (lambda _
+                   (wrap-program (string-append #$output "/bin/fetchmailconf")
+                    `("GUIX_PYTHONPATH" ":"
+                      prefix (,(getenv "GUIX_PYTHONPATH")))))))))
     (inputs
-     (list openssl))
+     (list openssl
+           ;; Needed for fetchmailconf
+           bash-minimal
+           python-future
+           python-wrapper))
     (home-page "https://www.fetchmail.info/")
     (synopsis "Remote-mail retrieval and forwarding utility")
     (description