diff mbox series

[bug#64628] gnu: Add emacs-persistent-scratch.

Message ID 79da4d8cef1b2bda8160835accc0f1104f8d0cd6.1689363177.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64628] gnu: Add emacs-persistent-scratch. | expand

Commit Message

Ahmad Draidi July 14, 2023, 7:32 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-persistent-scratch): New variable.
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: 917a299831361f253ea664f009176b4bbe06900a
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..7cfa8b84c2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34388,6 +34388,27 @@  (define-public emacs-persist
 variables.")
     (license license:gpl3+)))
 
+(define-public emacs-persistent-scratch
+  (package
+    (name "emacs-persistent-scratch")
+    (version "0.3.9")
+    (source (origin
+              (method git-fetch)
+              (file-name (git-file-name name version))
+              (uri (git-reference
+                    (url "https://github.com/Fanael/persistent-scratch")
+                    (commit version)))
+              (sha256
+               (base32
+                "187cyl005csmmmh292km1v3ffl8x49h5qyn87i4adz9l5sqnpdgj"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/Fanael/persistent-scratch")
+    (synopsis "Preserve the scratch buffer across Emacs sessions")
+    (description
+     "Preserve the state of scratch buffers across Emacs sessions by saving the
+state to and restoring it from a file, with auto-saving and backups.")
+    (license license:bsd-2)))
+
 (define-public emacs-company-emoji
   (package
     (name "emacs-company-emoji")