[bug#78198,1/3] gnu: Remove kopete.

Message ID 79c20631030245ac48cc84efce2c2ff71fbbc3b9.1746124584.git.z572@z572.online
State New
Headers
Series remove some kde package. |

Commit Message

Zheng Junjie May 1, 2025, 6:43 p.m. UTC
  This app is unmaintained and no longer released by the KDE community.

* gnu/packages/kde-internet.scm (kopete): Delete variable.

Change-Id: Idfcd4c63c7afbebc585633c917d4674ec501d1c3
---
 gnu/packages/kde-internet.scm | 77 -----------------------------------
 1 file changed, 77 deletions(-)
  

Patch

diff --git a/gnu/packages/kde-internet.scm b/gnu/packages/kde-internet.scm
index 4bf40afe887..2de76c21e0d 100644
--- a/gnu/packages/kde-internet.scm
+++ b/gnu/packages/kde-internet.scm
@@ -298,83 +298,6 @@  (define-public konversation
     (license ;; GPL for programs, FDL for documentation
      (list license:gpl2+ license:fdl1.2+))))
 
-(define-public kopete
-  (package
-    (name "kopete")
-    (version "23.04.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://kde/stable/release-service/" version
-                           "/src/kopete-" version ".tar.xz"))
-       (sha256
-        (base32 "1ps6g440p1dy2zwbj23f0mzw1d78r02aj88fy3i5sws9p9ra92gi"))))
-    (build-system qt-build-system)
-    (native-inputs
-     (list extra-cmake-modules kdoctools pkg-config))
-    (inputs
-     (list alsa-lib
-           boost
-           expat
-           glib
-           gpgme
-           jsoncpp
-           kcmutils
-           kconfig
-           kcontacts
-           kcoreaddons
-           kcrash
-           kdbusaddons
-           kdelibs4support
-           kdnssd
-           kemoticons
-           khtml
-           ki18n
-           kidentitymanagement
-           kjs
-           ;; TODO? kleopatra (additionally to libkleo)
-           knotifyconfig
-           kparts
-           kpimtextedit
-           ksyntaxhighlighting
-           ktexteditor
-           kwallet
-           ;; TODO: Libgadu
-           libidn
-           libkleo
-           ;; TODO: LibMeanwhile
-           libotr
-           libsrtp
-           libxml2
-           libxslt
-           mediastreamer2
-           openssl
-           ortp
-           phonon
-           qca
-           qgpgme
-           qtbase-5
-           speex
-           v4l-utils
-           ;; TODO: Xmms
-           zlib))
-    ;; TODO: enable video support
-    (home-page "https://apps.kde.org/kopete/")
-    (synopsis "Instant messaging and chat application")
-    (description "Kopete is an instant messenger supporting Jabber/XMPP ,AIM,
-ICQ, Gadu-Gadu, Novell GroupWise Messenger, and more.  It is designed to be a
-flexible and extensible multi-protocol system suitable for personal and
-enterprise use.
-
-The goal of Kopete is to provide users with a single easy-to-use way to access
-all of their instant messaging systems.  The interface puts people first, and
-is integrated with the system address book to let you access your contacts
-from other KDE applications.
-
-This package is part of the KDE networking module.")
-    (license ;; GPL for programs, LGPL for libraries, FDL for documentation
-     (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
-
 (define-public krdc
   (package
     (name "krdc")