diff mbox series

[bug#70282,v3] gnu: gnome-shell: Wrap screencast service.

Message ID 79b8bcd870f61cc79518c4ff8bf560b88661e0b3.1713718938.git.dariqq@posteo.net
State New
Headers show
Series [bug#70282,v3] gnu: gnome-shell: Wrap screencast service. | expand

Commit Message

Dariqq April 21, 2024, 5:02 p.m. UTC
Adjust screencast such that GI_TYPELIB_PATH and GST_PLUGIN_SYSTEM_PATH are set
before starting.

Add all required gstreamer plugins to inputs.

To be able to use it a running pipewire service is needed.

* gnu/packages/gnome.scm (gnome-shell):
[inputs]: Add gst-plugins-good and pipewire.
[#:phases]<'wrap-programs>: Wrap org.gnome.Shell.Screencast.

Change-Id: I2c31bf1bd92e281b86c57b06988c6a3793a58d40
---

Here is v3 which only uses js to set the environment variables.
Slight difference to before is that GST_PLUGIN_SYSTEM_PATH gets set to specific paths rather than prepending.
I've also tested if GI_TYPELIB_PATH can be set with GLib.setenv but that didn't seem to work,
so I 've used something similiar as in other places.

 gnu/packages/gnome.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)


base-commit: a1d711c92e119f6b5b8e99a620cdba92a4ca3bfb
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 489f23865b..b3c3fb72ad 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9392,6 +9392,7 @@  (define-public gnome-shell
             (add-after 'install 'wrap-programs
               (lambda* (#:key inputs #:allow-other-keys)
                 (let ((gi-typelib-path  (getenv "GI_TYPELIB_PATH"))
+                      (gst-plugin-path  (getenv "GST_PLUGIN_SYSTEM_PATH"))
                       (python-path
                        (string-join
                         (filter (lambda (item)
@@ -9411,6 +9412,18 @@  (define-public gnome-shell
                                     "path => imports.gi.GIRepository.Repository."
                                     "prepend_search_path(path));\n"
                                     all)))
+                  ;; Screencast requires a pipewire service running
+                  ;; (i.e. as provided by home-pipewire-service-type)
+                  (substitute* (string-append #$output "/share/gnome-shell/"
+                                              "org.gnome.Shell.Screencast")
+                    (("imports\\.package\\.start" all)
+                     (string-append "'" gi-typelib-path "'.split(':').forEach("
+                                    "path => imports.gi.GIRepository.Repository."
+                                    "prepend_search_path(path));\n"
+                                    "imports.gi.GLib.setenv('GST_PLUGIN_SYSTEM_PATH',"
+                                    "'" gst-plugin-path "'"
+                                    ", true);\n"
+                                    all)))
                   (for-each
                    (lambda (prog)
                      (wrap-program (string-append #$output "/bin/" prog)
@@ -9476,6 +9489,7 @@  (define-public gnome-shell
            gnome-settings-daemon
            graphene
            gst-plugins-base
+           gst-plugins-good
            ibus
            libcanberra
            libcroco
@@ -9486,6 +9500,7 @@  (define-public gnome-shell
            mesa-headers
            mutter
            network-manager-applet
+           pipewire
            polkit
            pulseaudio
            python-pygobject