diff mbox series

[bug#68368] gnu: Add r-dsb.

Message ID 79a84f556ed434e7a51f4fb87872872ef719719b.1704891744.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#68368] gnu: Add r-dsb. | expand

Commit Message

nafkhamdc Jan. 10, 2024, 1:02 p.m. UTC
* gnu/packages/bioconductor.scm (r-dsb): New variable.

Change-Id: I34b91da1ae177bd37cfa548c5f6fede453f29bcd
---
 gnu/packages/bioconductor.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 537768018ee03a6a9a5562022a16b47ac287d131

Comments

Ricardo Wurmus Jan. 10, 2024, 5:50 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a7af5c42ce..7c4272f8be 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5599,6 +5599,34 @@  (define-public r-dropletutils
 pseudo-cells, and downsampling of the count matrix.")
     (license license:gpl3)))
 
+;; This is a CRAN package, but it depends on r-limma from Bioconductor.
+(define-public r-dsb
+  (package
+    (name "r-dsb")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "dsb" version))
+       (sha256
+        (base32 "1xzhd4q04c1vql49r6m4zskpx7f5hkl5hmdgr3gsbxb73xfs51v2"))))
+    (properties `((upstream-name . "dsb")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-limma r-magrittr r-mclust))
+    (native-inputs (list r-knitr r-rmarkdown))
+    (home-page "https://github.com/niaid/dsb")
+    (synopsis
+     "Normalize & denoise droplet single cell protein data (CITE-Seq)")
+    (description
+     "R-dsb improves protein expression analysis in droplet-based single-cell studies.
+The package specifically addresses noise in raw protein UMI counts from methods like
+CITE-seq.  It identifies and removes two main sources of noise—protein-specific noise
+from unbound antibodies and droplet/cell-specific noise.  The package is applicable to
+various methods, including CITE-seq, REAP-seq, ASAP-seq, TEA-seq, and Mission Bioplatform
+data.  Check the vignette for tutorials on integrating dsb with Seurat and Bioconductor,
+and using dsb in Python.")
+    (license license:cc0)))
+
 (define-public r-dss
   (package
     (name "r-dss")