diff mbox series

[bug#70171,2/3] gnu: Add python-zipstream-ng.

Message ID 79a6fce081e0e28afd6630b3977aad5242173500.1712182575.git.takev@disroot.org
State New
Headers show
Series gnu: magic-wormhole: Update to 0.14.0 | expand

Commit Message

TakeV April 3, 2024, 10:21 p.m. UTC
* gnu/packages/python-xyz.scm (python-zipstream-ng): New variable.

Change-Id: Idf0c0d471aa1eda45cf649874f6a79b6b9a7937b
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9487b1fac9..e2afdc9024 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -36236,6 +36236,24 @@  (define-public python-zeroc-ice-3.6
                (base32
                 "0mikjfvq26kh8asnn9v55z41pap4c5ypymqnwwi4xkavc3mzyda2"))))))
 
+(define-public python-zipstream-ng
+  (package
+    (name "python-zipstream-ng")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "zipstream-ng" version))
+       (sha256
+        (base32 "1z4zdqqs2rg3z36khgj96bpggv34av337isfv7yxg32prawj687r"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest python-pytest-cov))
+    (home-page "https://github.com/pR0Ps/zipstream-ng")
+    (synopsis "A modern and easy to use streamable zip file generator")
+    (description
+     "This package provides a modern and easy to use streamable zip file generator")
+    (license license:lgpl3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar