diff mbox series

[bug#74213] gnu: Add r-seuratextend.

Message ID 797d9d30ec2c66d2e4eed6f9e6893a855c5189e3.1730825398.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#74213] gnu: Add r-seuratextend. | expand

Commit Message

Navid Afkhami Nov. 5, 2024, 4:49 p.m. UTC
* gnu/packages/cran.scm (r-seuratextend): New variable.

Change-Id: I9ce0d90a2f05d4e074459046c380849cf9f63978
---
 gnu/packages/cran.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)


base-commit: 4c56d0cccdc44e12484b26332715f54768738c5f
prerequisite-patch-id: 8f31c5ea3685b59fb6907a9582c0ca537c9c38bd

Comments

Navid Afkhami Nov. 5, 2024, 4:54 p.m. UTC | #1
Sent by mistake  Duplicate

 

- -  

Navid Afkhami

High Performance Computing (HPC)

Max Delbrück Center for Molecular Medicine (MDC)

Robert-Rössle-Straße 10, 13125 Berlin

Phone: +49 30 9406 1316

Email:   navid.afkhami@mdc-berlin.de
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab369c116c..b312c30099 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38320,6 +38320,53 @@  (define-public r-scattermore
 data to rasters.  It speeds up plotting of data with millions of points.")
     (license license:gpl3+)))
 
+(define-public r-seuratextend
+  (let ((commit "5382e921f7b365c7b75b20d07cb455e4390fe36f")
+        (revision "1"))
+    (package
+      (name "r-seuratextend")
+      (version (git-version "1.0.7" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/huayc09/SeuratExtend")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1rlx20jyfdrymxn8b9dsf9n9jk9rwjjx1wy2f00layvd57g9ch2q"))))
+      (properties `((upstream-name . "SeuratExtend")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-biocmanager
+                               r-dplyr
+                               r-ggplot2
+                               r-ggpubr
+                               r-glue
+                               r-hdf5r
+                               r-magrittr
+                               r-mosaic
+                               r-purrr
+                               r-remotes
+                               r-reshape2
+                               r-reticulate
+                               r-rlist
+                               r-scales
+                               r-seurat
+                               r-seuratextenddata
+                               r-seuratobject
+                               r-tidyr))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/huayc09/SeuratExtend")
+      (synopsis "Enhanced toolkit for scRNA-seq analysis")
+      (description
+       "This package is designed to improve and simplify the analysis of scRNA-seq data.
+It uses the Seurat object for this purpose.  It provides an array of
+enhanced visualization tools, an integrated functional and pathway
+analysis pipeline, seamless integration with popular Python tools,
+and a suite of utility functions to aid in data manipulation and
+presentation.")
+      (license license:gpl3+))))
+
 (define-public r-seuratextenddata
   (let ((commit "e7f17d4bacca436705b06b2cd0c879f83add9271")
         (revision "1"))