diff mbox series

[bug#68613] gnu: Add python-scikit-opt.

Message ID 7951a014460cd0928ef46de7336f8811009dc4bf.1705750860.git.timothee.mathieu@inria.fr
State New
Headers show
Series [bug#68613] gnu: Add python-scikit-opt. | expand

Commit Message

Timothee Mathieu Jan. 20, 2024, 11:41 a.m. UTC
* gnu/packages/python-science.scm (python-scikit-opt): New variable.

Change-Id: I47d6b35d9658a37a242b4db61d293fa7efd33802
---
 gnu/packages/python-science.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: 9c367ee1967b213b507a8bf041ea6c2623ceea96

Comments

Timothee Mathieu Jan. 26, 2024, 4:10 p.m. UTC | #1
I am not sure why QA fails to read my patch. This is my second package and I already had troubles with the first one (cf [ https://issues.guix.gnu.org/67051 | https://issues.guix.gnu.org/67051 ] ), although this time I used git sendmail to be sure that everything was formatted correctly so I don't know what went wrong.
Clément Lassieur Jan. 26, 2024, 10:15 p.m. UTC | #2
On Fri, Jan 26 2024, Timothee Mathieu wrote:

> I am not sure why QA fails to read my patch. This is my second package and I already had troubles with the first one (cf
> https://issues.guix.gnu.org/67051), although this time I used git sendmail to be sure that everything was formatted correctly so I don't know
> what went wrong.

Don't worry, it's not working at all.  I think they are changing the
ownership of their infra or something like that.

Clément
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 3c131fe730..b385f0b211 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -318,6 +318,27 @@  (define-public python-scikit-image
      "Scikit-image is a collection of algorithms for image processing.")
     (license license:bsd-3)))
 
+(define-public python-scikit-opt
+  (package
+    (name "python-scikit-opt")
+    (version "0.6.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "scikit-opt" version))
+       (sha256
+        (base32 "0ycqizgsj7q57asc1bphzhf1fx9zqn0vx5rli7q541bas64hfqiy"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-numpy python-scipy))
+    (home-page "https://github.com/guofei9987/scikit-opt")
+    (synopsis "Swarm Intelligence in Python")
+    (description
+     "Scikit-opt(or sko) is a Python module of Swarm Intelligence
+                  Algorithm.  Such as Genetic Algorithm, Particle Swarm Optimization,
+                  Simulated Annealing, Ant Colony Algorithm, Immune Algorithm,
+                  Artificial Fish Swarm Algorithm.")
+    (license license:expat)))
+
 (define-public python-scikit-optimize
   (package
     (name "python-scikit-optimize")