diff mbox series

[bug#53523,v3,1/2] gnu: Add tree-sitter.

Message ID 78ed09339d88b859d34798faff950ea7a2d4d6c9.1647300645.git.luishenriquegh2701@gmail.com
State Accepted
Headers show
Series [bug#53523,v3,1/2] gnu: Add tree-sitter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Luis Henrique Gomes Higino March 14, 2022, 11:31 p.m. UTC
* gnu/packages/text-editors.scm (tree-sitter): New variable.
---
 gnu/packages/text-editors.scm | 54 +++++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)

Comments

Pierre Langlois March 14, 2022, 11:43 p.m. UTC | #1
Hi Luis,

Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:

> * gnu/packages/text-editors.scm (tree-sitter): New variable.

I'm not a maintainer, but the patch looks good to me with just a minor
comment!

As mentioned before, I'll rebase on top of this after its merged, I
still have a bit more work to do on the emacs support for tree-sitter.

> ---
>  gnu/packages/text-editors.scm | 54 +++++++++++++++++++++++++++++++++++
>  1 file changed, 54 insertions(+)
>
> diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
> index 2c5f5de719..d333d78e22 100644
> --- a/gnu/packages/text-editors.scm
> +++ b/gnu/packages/text-editors.scm
> @@ -17,6 +17,7 @@
>  ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
>  ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
>  ;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
> +;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -39,6 +40,7 @@ (define-module (gnu packages text-editors)
>    #:use-module (guix gexp)
>    #:use-module (guix git-download)
>    #:use-module (guix utils)
> +  #:use-module (guix build utils)
>    #:use-module (guix build-system cargo)
>    #:use-module (guix build-system cmake)
>    #:use-module (guix build-system gnu)
> @@ -61,6 +63,7 @@ (define-module (gnu packages text-editors)
>    #:use-module (gnu packages gtk)
>    #:use-module (gnu packages guile)
>    #:use-module (gnu packages haskell-xyz)
> +  #:use-module (gnu packages icu4c)
>    #:use-module (gnu packages image)
>    #:use-module (gnu packages libbsd)
>    #:use-module (gnu packages libreoffice)
> @@ -1165,3 +1168,54 @@ (define-public virtaal
>  provided by the Translate Toolkit, including XLIFF and PO.")
>      (home-page "https://virtaal.translatehouse.org/")
>      (license license:gpl2+)))
> +
> +(define-public tree-sitter
> +  (package
> +    (name "tree-sitter")
> +    (version "0.20.6")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/tree-sitter/tree-sitter")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1z20518snyg0zp75qgs5bxmzjqws4dd19vnp6sya494za3qp5b6d"))
> +              (modules '((guix build utils)))
> +              (snippet '(begin
> +                          ;; Remove bundled ICU parts
> +                          (delete-file-recursively "lib/src/unicode")
> +                          #t))))
> +    (build-system gnu-build-system)
> +    (inputs (list icu4c))
> +    (arguments
> +     (list #:phases
> +           '(modify-phases %standard-phases
> +              (delete 'configure))
> +           #:tests? #f

It might be nice to add a short comment to say that there are no tests
for the runtime library itself.  A "; no check target." comment might
suffice, we do that often.

> +           #:make-flags
> +           #~(list (string-append "PREFIX="
> +                                  #$output)
> +                   (string-append "CC="
> +                                  #$(cc-for-target)))))
> +    (home-page "https://tree-sitter.github.io/tree-sitter/")
> +    (synopsis "Incremental parsing system for programming tools")
> +    (description
> +     "Tree-sitter is a parser generator tool and an incremental parsing
> +library.  It can build a concrete syntax tree for a source file and efficiently
> +update the syntax tree as the source file is edited.
> +
> +Tree-sitter aims to be:
> +
> +@itemize
> +@item General enough to parse any programming language
> +@item Fast enough to parse on every keystroke in a text editor
> +@item Robust enough to provide useful results even in the presence of syntax errors
> +@item Dependency-free so that the runtime library (which is written in pure C)
> +can be embedded in any application
> +@end itemize
> +
> +This package includes the @code{libtree-sitter} runtime library.
> +")
> +    (license license:expat)))

Thanks,
Pierre
diff mbox series

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 2c5f5de719..d333d78e22 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -39,6 +40,7 @@  (define-module (gnu packages text-editors)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix utils)
+  #:use-module (guix build utils)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
@@ -61,6 +63,7 @@  (define-module (gnu packages text-editors)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages haskell-xyz)
+  #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
   #:use-module (gnu packages libbsd)
   #:use-module (gnu packages libreoffice)
@@ -1165,3 +1168,54 @@  (define-public virtaal
 provided by the Translate Toolkit, including XLIFF and PO.")
     (home-page "https://virtaal.translatehouse.org/")
     (license license:gpl2+)))
+
+(define-public tree-sitter
+  (package
+    (name "tree-sitter")
+    (version "0.20.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tree-sitter/tree-sitter")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1z20518snyg0zp75qgs5bxmzjqws4dd19vnp6sya494za3qp5b6d"))
+              (modules '((guix build utils)))
+              (snippet '(begin
+                          ;; Remove bundled ICU parts
+                          (delete-file-recursively "lib/src/unicode")
+                          #t))))
+    (build-system gnu-build-system)
+    (inputs (list icu4c))
+    (arguments
+     (list #:phases
+           '(modify-phases %standard-phases
+              (delete 'configure))
+           #:tests? #f
+           #:make-flags
+           #~(list (string-append "PREFIX="
+                                  #$output)
+                   (string-append "CC="
+                                  #$(cc-for-target)))))
+    (home-page "https://tree-sitter.github.io/tree-sitter/")
+    (synopsis "Incremental parsing system for programming tools")
+    (description
+     "Tree-sitter is a parser generator tool and an incremental parsing
+library.  It can build a concrete syntax tree for a source file and efficiently
+update the syntax tree as the source file is edited.
+
+Tree-sitter aims to be:
+
+@itemize
+@item General enough to parse any programming language
+@item Fast enough to parse on every keystroke in a text editor
+@item Robust enough to provide useful results even in the presence of syntax errors
+@item Dependency-free so that the runtime library (which is written in pure C)
+can be embedded in any application
+@end itemize
+
+This package includes the @code{libtree-sitter} runtime library.
+")
+    (license license:expat)))