diff mbox series

[bug#68051] gnu: portmidi: Add variant portmidi-2 updated to release 2.0.4

Message ID 78e978968bbff5e9275bd1e75442eed18f15e8bb.1703625140.git.rimarko@libero.it
State New
Headers show
Series [bug#68051] gnu: portmidi: Add variant portmidi-2 updated to release 2.0.4 | expand

Commit Message

Marco Rimoldi Dec. 26, 2023, 9:22 p.m. UTC
Tested with package Frescobaldi. Other packages dependent on the old
217 version still need to be tested and updated so that it can be
phased out.

Change-Id: I2530d206e19e885082a95f1aac65348e7a51d4ca
---
 gnu/packages/music.scm | 37 +++++++++++++++++++++++++++++++++++--
 1 file changed, 35 insertions(+), 2 deletions(-)


base-commit: 103dc351111d7aff82b7b7883f79084faaa54abc
prerequisite-patch-id: d2b32b4a06c7f9485e7a5a468379691b11bbe14f
prerequisite-patch-id: 144bacd0445df999f7d91002d4878615c6961e85
prerequisite-patch-id: a80232287e9a25002622164250d2afdda0b70805
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6f1736a276..c485bf1620 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3047,6 +3047,39 @@  (define-public portmidi
 using a system-independent interface.")
     (license license:expat)))
 
+(define-public portmidi-2
+  (package
+    (name "portmidi")
+    (version "2.0.4")
+    (source (origin
+	      (method url-fetch)
+	      (uri (string-append
+		    "https://github.com/PortMidi/portmidi/archive/refs/tags/v"
+		    version ".zip"))
+	      (sha256
+	       (base32
+		"00xdlxd470zpbvvjb8km516y3mbpkv3487y1irn0qs1d38b18mys"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f              ; tests are interactive and can be found in the
+       #:configure-flags        ; pm_tests/ directory of the build tree
+       (list "-DBUILD_PORTMIDI_TESTS=On")
+       #:phases
+       (modify-phases %standard-phases
+	 (add-after 'unpack 'fix-version
+	   (lambda _ (substitute* "CMakeLists.txt"
+                       (("2.0.3") (version))))))))
+    (inputs
+     (list alsa-lib))
+    (native-inputs
+     (list unzip))
+    (home-page "https://github.com/PortMidi/")
+    (synopsis "Library for MIDI I/O")
+    (description
+     "PortMidi is a library supporting real-time input and output of MIDI data
+using a system-independent interface.")
+    (license license:expat)))
+
 (define-public python-pyportmidi
   (let ((commit "d9e5ee00b208b09618fa0d4a5bbce3c9c077b386")
         (revision "0"))
@@ -3062,7 +3095,7 @@  (define-public python-pyportmidi
                 (file-name (git-file-name name version))))
       (build-system python-build-system)
       (inputs
-        (list portmidi alsa-lib))
+        (list portmidi-2 alsa-lib))
       (native-inputs
         (list python-cython))
       (home-page "https://github.com/PortMidi")
@@ -3098,7 +3131,7 @@  (define-public frescobaldi
     (inputs
      (list lilypond
            poppler
-           portmidi
+           portmidi-2
            python-ly
            python-poppler-qt5
            python-pyportmidi