[bug#77148,9/9] gnu: Add ovmf-loongarch64.

Message ID 78e614438f4b7e4f07be2b764eeb71d41875607e.1742546953.git.efraim@flashner.co.il
State New
Headers
Series New firmware and updates |

Commit Message

Efraim Flashner March 21, 2025, 8:53 a.m. UTC
  * gnu/packages/firmware.scm (ovmf-loongarch64): New variable.
(make-ovmf-firmware)[arguments]: Adjust the 'build phase to add a case
for loongarch64.

Change-Id: Ibb916b50fd3dc7831ac895cb8b59695688750377
---
 gnu/packages/firmware.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Comments

Maxim Cournoyer March 22, 2025, 7:33 a.m. UTC | #1
Hello,

Efraim Flashner <efraim@flashner.co.il> writes:

> * gnu/packages/firmware.scm (ovmf-loongarch64): New variable.
> (make-ovmf-firmware)[arguments]: Adjust the 'build phase to add a case
> for loongarch64.
>
> Change-Id: Ibb916b50fd3dc7831ac895cb8b59695688750377
> ---
>  gnu/packages/firmware.scm | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
> index fe2956fbfdf..6f784a281d3 100644
> --- a/gnu/packages/firmware.scm
> +++ b/gnu/packages/firmware.scm
> @@ -1090,6 +1090,8 @@ (define* (make-ovmf-firmware arch)
>                                  "ArmVirtPkg/ArmVirtQemu.dsc")
>                                 ("riscv64"
>                                  "OvmfPkg/RiscVVirt/RiscVVirtQemu.dsc")
> +                               ("loongarch64"
> +                                "OvmfPkg/LoongArchVirt/LoongArchVirtQemu.dsc")
>                                 (_ #t)))))
>              (add-before 'install 'install-efi-shell
>                (lambda _
> @@ -1247,6 +1249,25 @@ (define-public ovmf-riscv64
>                        (install-file "RISCV_VIRT_CODE.fd" fmw)
>                        (install-file "RISCV_VIRT_VARS.fd" fmw))))))))))))
>  
> +(define-public ovmf-loongarch64
> +  (let ((base (make-ovmf-firmware "loongarch64")))
> +    (package
> +      (inherit base)
> +      (arguments
> +        (substitute-keyword-arguments (package-arguments base)
> +          ((#:phases phases)
> +           #~(modify-phases #$phases
> +               (replace 'install
> +                 (lambda _
> +                   (let ((fmw (string-append #$output "/share/firmware")))
> +                     (mkdir-p fmw)

Nitpick: fw is more commond than fwm as an abbrevation.

> +                     (with-directory-excursion "Build/LoongArchVirtQemu/RELEASE_GCC/FV"

Other nitpick: I'd break the directory part on a newline to fit under 80
columns, per our code style guidelines.

Otherwise, my general comments elsewhere apply it too, but it LGTM
otherwise.

I think we should add the QEMU firmware descriptors everywhere so that
they'll be usable with the libvirt-configuration firmwares field I
proposed in bug#77110.  Perhaps we can apply that one first to make this
slightly easier (it provided some `ovmf-aux-file' procedure you'll
probably want to use to locate the a locally kept .json QEMU firmware
descriptor file).
  
Efraim Flashner March 23, 2025, 3:23 p.m. UTC | #2
On Sat, Mar 22, 2025 at 04:33:37PM +0900, Maxim Cournoyer wrote:
> Hello,
> 
> Efraim Flashner <efraim@flashner.co.il> writes:
> 
> > * gnu/packages/firmware.scm (ovmf-loongarch64): New variable.
> > (make-ovmf-firmware)[arguments]: Adjust the 'build phase to add a case
> > for loongarch64.
> >
> > Change-Id: Ibb916b50fd3dc7831ac895cb8b59695688750377
> > ---
> >  gnu/packages/firmware.scm | 21 +++++++++++++++++++++
> >  1 file changed, 21 insertions(+)
> >
> > diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
> > index fe2956fbfdf..6f784a281d3 100644
> > --- a/gnu/packages/firmware.scm
> > +++ b/gnu/packages/firmware.scm
> > @@ -1090,6 +1090,8 @@ (define* (make-ovmf-firmware arch)
> >                                  "ArmVirtPkg/ArmVirtQemu.dsc")
> >                                 ("riscv64"
> >                                  "OvmfPkg/RiscVVirt/RiscVVirtQemu.dsc")
> > +                               ("loongarch64"
> > +                                "OvmfPkg/LoongArchVirt/LoongArchVirtQemu.dsc")
> >                                 (_ #t)))))
> >              (add-before 'install 'install-efi-shell
> >                (lambda _
> > @@ -1247,6 +1249,25 @@ (define-public ovmf-riscv64
> >                        (install-file "RISCV_VIRT_CODE.fd" fmw)
> >                        (install-file "RISCV_VIRT_VARS.fd" fmw))))))))))))
> >  
> > +(define-public ovmf-loongarch64
> > +  (let ((base (make-ovmf-firmware "loongarch64")))
> > +    (package
> > +      (inherit base)
> > +      (arguments
> > +        (substitute-keyword-arguments (package-arguments base)
> > +          ((#:phases phases)
> > +           #~(modify-phases #$phases
> > +               (replace 'install
> > +                 (lambda _
> > +                   (let ((fmw (string-append #$output "/share/firmware")))
> > +                     (mkdir-p fmw)
> 
> Nitpick: fw is more commond than fwm as an abbrevation.
> 
> > +                     (with-directory-excursion "Build/LoongArchVirtQemu/RELEASE_GCC/FV"
> 
> Other nitpick: I'd break the directory part on a newline to fit under 80
> columns, per our code style guidelines.
> 
> Otherwise, my general comments elsewhere apply it too, but it LGTM
> otherwise.
> 
> I think we should add the QEMU firmware descriptors everywhere so that
> they'll be usable with the libvirt-configuration firmwares field I
> proposed in bug#77110.  Perhaps we can apply that one first to make this
> slightly easier (it provided some `ovmf-aux-file' procedure you'll
> probably want to use to locate the a locally kept .json QEMU firmware
> descriptor file).

Sounds good to me.
  
Maxim Cournoyer March 27, 2025, 12:26 p.m. UTC | #3
Hi Efraim,

[...]

>> I think we should add the QEMU firmware descriptors everywhere so that
>> they'll be usable with the libvirt-configuration firmwares field I
>> proposed in bug#77110.  Perhaps we can apply that one first to make this
>> slightly easier (it provided some `ovmf-aux-file' procedure you'll
>> probably want to use to locate the a locally kept .json QEMU firmware
>> descriptor file).
>
> Sounds good to me.

I've now merged bug#77110, so feel free to go ahead and add the relevant
.json QEMU firmware descriptors that'll make the firmware usable with
our libvirt service.
  

Patch

diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index fe2956fbfdf..6f784a281d3 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1090,6 +1090,8 @@  (define* (make-ovmf-firmware arch)
                                 "ArmVirtPkg/ArmVirtQemu.dsc")
                                ("riscv64"
                                 "OvmfPkg/RiscVVirt/RiscVVirtQemu.dsc")
+                               ("loongarch64"
+                                "OvmfPkg/LoongArchVirt/LoongArchVirtQemu.dsc")
                                (_ #t)))))
             (add-before 'install 'install-efi-shell
               (lambda _
@@ -1247,6 +1249,25 @@  (define-public ovmf-riscv64
                       (install-file "RISCV_VIRT_CODE.fd" fmw)
                       (install-file "RISCV_VIRT_VARS.fd" fmw))))))))))))
 
+(define-public ovmf-loongarch64
+  (let ((base (make-ovmf-firmware "loongarch64")))
+    (package
+      (inherit base)
+      (arguments
+        (substitute-keyword-arguments (package-arguments base)
+          ((#:phases phases)
+           #~(modify-phases #$phases
+               (replace 'install
+                 (lambda _
+                   (let ((fmw (string-append #$output "/share/firmware")))
+                     (mkdir-p fmw)
+                     (with-directory-excursion "Build/LoongArchVirtQemu/RELEASE_GCC/FV"
+                       ;; Make the files the desired length and then install them
+                       (truncate-file "QEMU_EFI.fd" (* 16 1024 1024))
+                       (truncate-file "QEMU_VARS.fd" (* 16 1024 1024))
+                       (install-file "QEMU_EFI.fd" fmw)
+                       (install-file "QEMU_VARS.fd" fmw))))))))))))
+
 (define-public ovmf
   (deprecated-package "ovmf" ovmf-x86-64))