diff mbox series

[bug#64778,3/5] gnu: Add go-github-com-marcinbor85-gohex

Message ID 78b4f29776ff534140430460865884dc61c3efa2.1689982943.git.karl@hallsby.com
State New
Headers show
Series Add wally-cli | expand

Commit Message

Karl Hallsby July 21, 2023, 11:50 p.m. UTC
* gnu/packages/golang.scm (go-github-com-marcinbor85-gohex): New
variable. Init on commit 55fb1c62 (master at the time).
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e2ce6bc890..90f80c7e27 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12184,6 +12184,28 @@  (define-public aws-vault
     (home-page "https://github.com/99designs/aws-vault")
     (license license:expat)))
 
+(define-public go-github-com-marcinbor85-gohex
+  (let ((commit "55fb1c624d845f0f5b79ee946cf09a15cb50ed89")
+        (revision "0"))
+    (package
+      (name "go-github-com-marcinbor85-gohex")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/marcinbor85/gohex")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0klzqnvmkx6xvy9kc7hbsgpsdcrswnljsq8frf0jxddxi27qh1hn"))))
+      (build-system go-build-system)
+      (arguments '(#:import-path "github.com/marcinbor85/gohex"))
+      (home-page "https://github.com/marcinbor85/gohex")
+      (synopsis "A Go library for parsing Intel HEX files")
+      (description "A Go library for parsing Intel HEX files")
+      (license license:expat))))
+
 (define-public go-github-com-gsterjov-go-libsecret
   (let ((commit "a6f4afe4910cad8688db3e0e9b9ac92ad22d54e1")
         (revision "0"))