[bug#76633] gnu: Add emacs-org-gnosis.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-org-gnosis): New variable.
Change-Id: I2eea20962cf64402ab7f2c9b34385bcfcf6f47ce
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
base-commit: 4270c484ca174ad97d1add91fa5fc69041a6af9d
Comments
Hey Thanos, TY!
On 2025-02-28 10:29, Thanos Apollo wrote:
> * gnu/packages/emacs-xyz.scm (emacs-org-gnosis): New variable.
> [...]
> + (description
> + "Org Gnosis is a knowledge management tool that leverages Org mode
> +for storing notes & journal entries, integrating them with an
> +SQLite database for efficient retrieval and relationship mapping.")
> + (license license:gpl3+)))
When I look at the home-page, I see a pretty different description. In
particular, "spaced repetition" is not there..
Nicolas Graves <ngraves@ngraves.fr> writes:
> On 2025-02-28 10:29, Thanos Apollo wrote:
>
>> * gnu/packages/emacs-xyz.scm (emacs-org-gnosis): New variable.
>> [...]
>> + (description
>> + "Org Gnosis is a knowledge management tool that leverages Org mode
>> +for storing notes & journal entries, integrating them with an
>> +SQLite database for efficient retrieval and relationship mapping.")
>> + (license license:gpl3+)))
>
> When I look at the home-page, I see a pretty different description. In
> particular, "spaced repetition" is not there..
I've sent a patch fixing the homepage URL, thanks for noticing Nicolas.
@@ -39682,6 +39682,29 @@ (define-public emacs-org-glossary
across all Org export back-ends.")
(license license:gpl3+))))
+(define-public emacs-org-gnosis
+ (package
+ (name "emacs-org-gnosis")
+ (version "0.0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.thanosapollo.org/org-gnosis")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15r305lbci797nlh6m3xy1q0cwfz85x7k76adp71z8706n2w9j71"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat emacs-emacsql))
+ (home-page "https://thanosapollo.org/projects/gnosis")
+ (synopsis "Roam-like note taking system.")
+ (description
+ "Org Gnosis is a knowledge management tool that leverages Org mode
+for storing notes & journal entries, integrating them with an
+SQLite database for efficient retrieval and relationship mapping.")
+ (license license:gpl3+)))
+
(define-public emacs-uml-mode
;; Package has no release. Version is extracted from "Version:" keyword in
;; main file.