[bug#76633] gnu: Add emacs-org-gnosis.

Message ID 78b32f78de8a3850d2fb7bf0f165d5ab068f9d6e.1740731293.git.public@thanosapollo.org
State New
Headers
Series [bug#76633] gnu: Add emacs-org-gnosis. |

Commit Message

Thanos Apollo Feb. 28, 2025, 8:29 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-org-gnosis): New variable.

Change-Id: I2eea20962cf64402ab7f2c9b34385bcfcf6f47ce
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 4270c484ca174ad97d1add91fa5fc69041a6af9d
  

Comments

Nicolas Graves Feb. 28, 2025, 9:20 a.m. UTC | #1
Hey Thanos, TY!


On 2025-02-28 10:29, Thanos Apollo wrote:

> * gnu/packages/emacs-xyz.scm (emacs-org-gnosis): New variable.
> [...]
> +    (description
> +     "Org Gnosis is a knowledge management tool that leverages Org mode
> +for storing notes & journal entries, integrating them with an
> +SQLite database for efficient retrieval and relationship mapping.")
> +    (license license:gpl3+)))

When I look at the home-page, I see a pretty different description.  In
particular, "spaced repetition" is not there..
  
Thanos Apollo Feb. 28, 2025, 10:43 a.m. UTC | #2
Nicolas Graves <ngraves@ngraves.fr> writes:

> On 2025-02-28 10:29, Thanos Apollo wrote:
>
>> * gnu/packages/emacs-xyz.scm (emacs-org-gnosis): New variable.
>> [...]
>> +    (description
>> +     "Org Gnosis is a knowledge management tool that leverages Org mode
>> +for storing notes & journal entries, integrating them with an
>> +SQLite database for efficient retrieval and relationship mapping.")
>> +    (license license:gpl3+)))
>
> When I look at the home-page, I see a pretty different description.  In
> particular, "spaced repetition" is not there..

I've sent a patch fixing the homepage URL, thanks for noticing Nicolas.
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 272be3a275..af5811a8f6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -39682,6 +39682,29 @@  (define-public emacs-org-glossary
 across all Org export back-ends.")
       (license license:gpl3+))))
 
+(define-public emacs-org-gnosis
+  (package
+    (name "emacs-org-gnosis")
+    (version "0.0.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.thanosapollo.org/org-gnosis")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15r305lbci797nlh6m3xy1q0cwfz85x7k76adp71z8706n2w9j71"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat emacs-emacsql))
+    (home-page "https://thanosapollo.org/projects/gnosis")
+    (synopsis "Roam-like note taking system.")
+    (description
+     "Org Gnosis is a knowledge management tool that leverages Org mode
+for storing notes & journal entries, integrating them with an
+SQLite database for efficient retrieval and relationship mapping.")
+    (license license:gpl3+)))
+
 (define-public emacs-uml-mode
   ;; Package has no release.  Version is extracted from "Version:" keyword in
   ;; main file.