diff mbox series

[bug#66858,7/7] gnu: Add plasma-shell-wallpaper-active-blur.

Message ID 7864db3d6d178e737e763b2cf13af02b70e1caca.1698783239.git.sughosha@disroot.org
State New
Headers show
Series Add some themes and extensions for KDE Plasma. | expand

Commit Message

Sughosha Oct. 31, 2023, 8:19 p.m. UTC
* gnu/packages/kde-xyz.scm (plasma-shell-wallpaper-active-blur): New variable.

Change-Id: I612d5885b65779100aee41879701df499b0b863b
---
 gnu/packages/kde-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-xyz.scm b/gnu/packages/kde-xyz.scm
index c9e8308fbf..f98a9c4af9 100644
--- a/gnu/packages/kde-xyz.scm
+++ b/gnu/packages/kde-xyz.scm
@@ -218,3 +218,28 @@  (define-public plasma-shell-applet-window-title
      "This plasmoid shows the current window title and icon in Plasma panels or
 Latte Dock.")
     (license license:gpl2+)))
+
+(define-public plasma-shell-wallpaper-active-blur
+  (package
+    (name "plasma-shell-wallpaper-active-blur")
+    (version "2.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/bouteillerAlan/blurredwallpaper")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0b688d4p8n1wkhw3bp1zhxi5xbx806fy5hcgc8jrjj2kaclk408n"))))
+    (build-system copy-build-system)
+    (arguments
+     `(#:install-plan
+       `(("." "/share/plasma/wallpapers/a2n.blur"
+          #:include-regexp ("/assets/" "/contents/" "metadata.json")))))
+    (home-page "https://github.com/bouteillerAlan/blurredwallpaper")
+    (synopsis "Blurred wallpaper plugin for Plasma shell")
+    (description
+     "This Plasma wallpaper plugin blurs the wallpaper when a window is
+active.")
+    (license license:gpl2+)))