diff mbox series

[bug#49221,v2,1/2] gnu: go-github-com-bmatcuk-doublestar: Remove test incompatible with go-1.16.

Message ID 7857e451389aa8081dac1bb783c5c7d29f2e9189.1628192044.git.iskarian@mgsn.dev
State Accepted
Headers show
Series [bug#49221,v2,1/2] gnu: go-github-com-bmatcuk-doublestar: Remove test incompatible with go-1.16. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Aug. 5, 2021, 8:20 p.m. UTC
* gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/golang.scm (go-github-com-bmatcuk-doublestar): Use it.
---
 gnu/local.mk                                      |  1 +
 gnu/packages/golang.scm                           |  5 ++++-
 ...b-com-bmatcuk-doublestar-1.3-remove-test.patch | 15 +++++++++++++++
 3 files changed, 20 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch


base-commit: fd3f1e809234c3e675d2eb8bc17774b0d4a94b0c
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 61ac39618a..5b2e64a8b8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1183,6 +1183,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/gobject-introspection-girepository.patch	\
   %D%/packages/patches/go-fix-script-tests.patch			\
   %D%/packages/patches/go-skip-gc-test.patch			\
+  %D%/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch	\
   %D%/packages/patches/gpm-glibc-2.26.patch			\
   %D%/packages/patches/gpodder-disable-updater.patch		\
   %D%/packages/patches/gpsbabel-fix-i686-test.patch		\
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 89020648f0..cf72aa6e20 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6480,7 +6480,10 @@  template functions.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))))
+                "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))
+              (patches
+               (search-patches
+                "go-github-com-bmatcuk-doublestar-1.3-remove-test.patch"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/bmatcuk/doublestar"))
diff --git a/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch b/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
new file mode 100644
index 0000000000..2c64575914
--- /dev/null
+++ b/gnu/packages/patches/go-github-com-bmatcuk-doublestar-1.3-remove-test.patch
@@ -0,0 +1,15 @@ 
+Remove test which fails with Go >= 1.15 due to API changes.
+This patch should no longer be necessary with doublestar v4+
+
+diff --git a/doublestar_test.go b/doublestar_test.go
+index b21d20ad4b..f510c3d06b 100644
+--- a/doublestar_test.go
++++ b/doublestar_test.go
+@@ -80,7 +80,6 @@ var matchTests = []MatchTest{
+ 	{"[", "a", false, ErrBadPattern, true},
+ 	{"[^", "a", false, ErrBadPattern, true},
+ 	{"[^bc", "a", false, ErrBadPattern, true},
+-	{"a[", "a", false, nil, false},
+ 	{"a[", "ab", false, ErrBadPattern, true},
+ 	{"*x", "xxx", true, nil, true},
+ 	{"[abc]", "b", true, nil, true},