diff mbox series

[bug#63226,2/2] gnu: neovim: Update to 0.9.0.

Message ID 78488899ee6b6edb26e4982f17ab7a38ef47ed1b.1683014300.git.me@gyara.moe
State New
Headers show
Series [bug#63226,1/2] gnu: tree-sitter: Update to 0.20.8. | expand

Commit Message

ギャラ May 2, 2023, 7:58 a.m. UTC
* gnu/packages/vim.scm (neovim): Update to 0.9.0.
[arguments]: CompileFlags.cmake is gone, use versiondef.h.in instead.
---
 gnu/packages/vim.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Greg Hogan May 2, 2023, 3:13 p.m. UTC | #1
On Tue, May 2, 2023 at 3:59 AM ギャラ via Guix-patches via
<guix-patches@gnu.org> wrote:
>                     ;; doubles its size.  We remove the refirence here.

63227 looks to be identical except also fixing the spelling of
"refirence" to reference.
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index d555194d0b..7d975efcc8 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -693,7 +693,7 @@  (define-public neovim-syntastic
 (define-public neovim
   (package
     (name "neovim")
-    (version "0.8.3")
+    (version "0.9.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -702,7 +702,7 @@  (define-public neovim
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1zff73yxbnxym6sn43xk6r0zc2ncingsib81v9g39ibrcinpwaa9"))))
+                "0xsvhm191cy5ivcw0c8dnpzbpcvvn5hsnkzkipr2aabgrsgqj628"))))
     (build-system cmake-build-system)
     (arguments
      (list #:modules
@@ -752,7 +752,7 @@  (define-public neovim
                    ;; nvim remembers its build options, including the compiler with
                    ;; its complete path.  This adds gcc to the closure of nvim, which
                    ;; doubles its size.  We remove the refirence here.
-                   (substitute* "cmake/GetCompileFlags.cmake"
+                   (substitute* "cmake.config/versiondef.h.in"
                      (("\\$\\{CMAKE_C_COMPILER\\}") "/gnu/store/.../bin/gcc"))
                    #t)))))
     (inputs (list libuv-for-luv