diff mbox series

[bug#63793] gnu: sbsigntools: Update to 0.9.5.

Message ID 782d12b0f1d53565166394065415862fba56bff1.1685397220.git.kiasoc5@disroot.org
State New
Headers show
Series [bug#63793] gnu: sbsigntools: Update to 0.9.5. | expand

Commit Message

kiasoc5 May 29, 2023, 9:53 p.m. UTC
This fixes a build failure with openssl-3.

* gnu/packages/efi.scm (sbsigntools): Update to 0.9.5.
[arguments]: Remove trailing #t's. Use Gexps. Use "this-package-input". Simplify lambdas.
[inputs]: Remove labels.
---
 gnu/packages/efi.scm | 58 +++++++++++++++++++++-----------------------
 1 file changed, 28 insertions(+), 30 deletions(-)


base-commit: b96b82bcd4bc24529941ff74a91432481f1a71b5

Comments

Felix Lechner May 31, 2023, 2:49 p.m. UTC | #1
Hi,

There is a merged duplicate to this bug that may be hidden in Mumi.
The two bugs are Bug#63793 and Bug#63635. The linkage may be easier to
see in Debbugs.

Kind regards
Felix
diff mbox series

Patch

diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 75eb24bf86..50d52c4d65 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -30,6 +30,7 @@  (define-module (gnu packages efi)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix utils)
@@ -99,7 +100,7 @@  (define-public efi-analyzer
 (define-public sbsigntools
   (package
     (name "sbsigntools")
-    (version "0.9.4")
+    (version "0.9.5")
     (source
      (origin
        (method git-fetch)
@@ -110,34 +111,31 @@  (define-public sbsigntools
          (recursive? #t)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1y76wy65y6k10mjl2dm5hb5ms475alr4s080xzj8y833x01xvf3m"))))
+        (base32 "060n6w0dx1mrilhdv482ncckanqz6pdv53piimiki0bm15d2fcp4"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-more-shebangs
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "lib/ccan.git/tools/create-ccan-tree"
-              (("#!/bin/bash")
-               (string-append "#!"
-                              (assoc-ref inputs "bash")
-                              "/bin/bash")))
-             #t))
-         (add-after 'unpack 'patch
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (substitute* '("configure.ac"
-                            "tests/Makefile.am")
-              (("/usr/include/efi")
-               (string-append (assoc-ref inputs "gnu-efi")
-                              "/include/efi"))
-              (("/usr/lib/gnuefi")
-               (string-append (assoc-ref inputs "gnu-efi")
-                              "/lib")))
-             #t))
-         (add-after 'unpack 'setenv
-           (lambda _
-             (setenv "CC" "gcc")
-             #t)))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-more-shebangs
+                 (lambda _
+                   (substitute* "lib/ccan.git/tools/create-ccan-tree"
+                     (("#!/bin/bash")
+                      (string-append "#!"
+                                     #$(this-package-native-input "bash")
+                                     "/bin/bash")))))
+               (add-after 'unpack 'patch
+                 (lambda _
+                   (substitute* '("configure.ac"
+                                  "tests/Makefile.am")
+                     (("/usr/include/efi")
+                      (string-append #$(this-package-input "gnu-efi")
+                                     "/include/efi"))
+                     (("/usr/lib/gnuefi")
+                      (string-append #$(this-package-input "gnu-efi")
+                                     "/lib")))))
+               (add-after 'unpack 'setenv
+                 (lambda _
+                   (setenv "CC" "gcc"))))))
     (native-inputs
      (list autoconf
            automake
@@ -146,9 +144,9 @@  (define-public sbsigntools
            pkg-config
            util-linux)) ; getopt
     (inputs
-     `(("gnu-efi" ,gnu-efi)
-       ("libuuid" ,util-linux "lib")
-       ("openssl" ,openssl)))
+     (list gnu-efi
+           `(,util-linux "lib") ; libuuid
+           openssl))
     (synopsis "EFI signing tools")
     (description "This package provides tools for signing EFI binaries.")
     (home-page "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git/")