diff mbox series

[bug#39312] gnu: Add chatty.

Message ID 77f67f99-44e6-6464-cf96-62eec29493d6@web.de
State Accepted
Headers show
Series [bug#39312] gnu: Add chatty. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Jonathan Brielmaier Jan. 27, 2020, 6:25 p.m. UTC
Hi,

attached is a patch for Chatty. A GUI program for SMS and XMPP optimized
for mobile interfaces. XMPP works nicely already. SMS not yet: I have
the required package "purple-mm-sms" already in my local git, but
couldn't test it yet, because I lack the hardware. I'll submit it
separately as soon it's ready and tested :)

~Jonathan

Comments

Maja Kądziołka March 24, 2020, 3:48 p.m. UTC | #1
tags 39312 moreinfo
thanks

Hi there,

what is the status of this patch? Could you fix the issues mentioned in
[0] and send an updated patch, or is that something you don't feel like
pursuing?

[0]: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=39312#17
Jonathan Brielmaier March 24, 2020, 5:40 p.m. UTC | #2
Hi Jakub,

thanks for the heads up. I continued some work but in the mean-time
chatty got a new dependency which has still failing tests. I'll post a
new patch series in the coming days...

All in all, this patch suite is not really urgent :P

On 24.03.20 16:48, Jakub Kądziołka wrote:
> tags 39312 moreinfo
> thanks
>
> Hi there,
>
> what is the status of this patch? Could you fix the issues mentioned in
> [0] and send an updated patch, or is that something you don't feel like
> pursuing?
>
> [0]: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=39312#17
>
Jonathan Brielmaier April 13, 2020, 5:25 p.m. UTC | #3
Hi Jakub,

I finally got the new dependency (feedbackd) building.

The status of the patch series:
* compared to the previous version I moved several inputs around
* chatty runs and XMPP functionality is fine, SMS is still unknown as I
  don't have a proper device for testing
* feedbackd builds but I don't know if its really working for the same
  reason as above
* feedbackd could maybe go to another module, but audio.scm doesn't
  really fit as it also provides haptic feedback...

All in all I think it should be in a state to be merged into master.
Further improvements can be done in master. Should be easier.

Jonathan Brielmaier (3):
  gnu: Add feedbackd.
  gnu: Add purple-mm-sms.
  gnu: Add chatty.

 gnu/packages/gnome.scm     | 36 +++++++++++++++++-
 gnu/packages/messaging.scm | 76 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 111 insertions(+), 1 deletion(-)

--
2.26.0
Jonathan Brielmaier May 11, 2020, 4:16 p.m. UTC | #4
Changes compared to v2:
* rebased on current master
* updated feedbackd to most current release
* updated chatty to 1.10.0 and propagated evolution-data-service as it otherwise would not start

Jonathan Brielmaier (3):
  gnu: Add feedbackd.
  gnu: Add purple-mm-sms.
  gnu: Add chatty.

 gnu/packages/gnome.scm     | 36 +++++++++++++++++-
 gnu/packages/messaging.scm | 76 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 111 insertions(+), 1 deletion(-)

--
2.26.2
diff mbox series

Patch

From d746b3b01acdec8a4ce6a508a063f951dd9e74f6 Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Mon, 27 Jan 2020 19:10:10 +0100
Subject: [PATCH] gnu: Add chatty.

* gnu/packages/messaging.scm (chatty): New variable.
---
 gnu/packages/messaging.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 839f718134..e66d10b0e9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -55,6 +56,7 @@ 
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages enchant)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
@@ -1995,4 +1997,40 @@  support for high performance Telegram Bot creation.")
       (home-page "https://core.telegram.org/tdlib")
       (license license:boost1.0))))

+(define-public chatty
+ (package
+   (name "chatty")
+   (version "0.1.7")
+   (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://source.puri.sm/Librem5/chatty.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1prqd2dnib3j12pjiplzr2rim9q617vmvzv76lgmz0n3bmp7v7ma"))))
+   (build-system meson-build-system)
+   (native-inputs
+     `(("desktop-file-utils" ,desktop-file-utils) ;for update-desktop-database
+       ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+       ("folks" ,folks)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("libgcrypt" ,libgcrypt)
+       ("libgee" ,libgee)
+       ("libhandy" ,libhandy)
+       ("pidgin" ,pidgin)
+       ("purple-mm-sms" ,purple-mm-sms)
+       ("pkg-config" ,pkg-config)
+       ("sqlite" ,sqlite)))
+   (propagated-inputs
+     `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+   (synopsis "Mobile client for XMPP and SMS messaging")
+   (description "Chatty is a chat program for XMPP and SMS.  It works on mobile
+as well as on desktop platforms.  It's based on libpurple and ModemManager.")
+   (home-page "https://source.puri.sm/Librem5/chatty")
+   (license license:gpl3+)))
+
 ;;; messaging.scm ends here
--
2.25.0