diff mbox series

[bug#68555,1/3] gnu: Add trisquel-keyring.

Message ID 77e75c87e83ba6951c6a977f014af4ead5700831.1705531484.git.GNUtoo@cyberdimension.org
State New
Headers show
Series debootstrap: Add Trisquel support. | expand

Commit Message

Denis 'GNUtoo' Carikli Jan. 17, 2024, 11:29 p.m. UTC
* gnu/packages/debian.scm (trisquel-keyring): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/debian.scm | 50 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

Comments

Efraim Flashner Jan. 19, 2024, 9:38 a.m. UTC | #1
I'm not against adding both keyrings, but they should be in separate
commits.  Also, are there scripts to build the keyrings (like debian) or
are there not really and its just the released keyring file?

On Thu, Jan 18, 2024 at 12:29:53AM +0100, Denis 'GNUtoo' Carikli wrote:
> * gnu/packages/debian.scm (trisquel-keyring): New variable.
> 
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
> ---
>  gnu/packages/debian.scm | 50 +++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 50 insertions(+)
> 
> diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
> index de43182172..4e398f619c 100644
> --- a/gnu/packages/debian.scm
> +++ b/gnu/packages/debian.scm
> @@ -2,6 +2,7 @@
>  ;;; Copyright © 2018, 2020-2024 Efraim Flashner <efraim@flashner.co.il>
>  ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
>  ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
> +;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -24,6 +25,7 @@ (define-module (gnu packages debian)
>    #:use-module (guix git-download)
>    #:use-module (guix gexp)
>    #:use-module (guix packages)
> +  #:use-module (guix build-system copy)
>    #:use-module (guix build-system gnu)
>    #:use-module (guix build-system trivial)
>    #:use-module (gnu packages autotools)
> @@ -146,6 +148,54 @@ (define-public debian-ports-archive-keyring
>      ;; "The keys in the keyrings don't fall under any copyright."
>      (license license:public-domain)))
>  
> +(define-public pureos-archive-keyring
> +  (package
> +    (name "pureos-archive-keyring")
> +    (version "2021.11.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://repo.puri.sm/pureos/pool/main/p/pureos-archive-keyring/"
> +                    "pureos-archive-keyring_" version ".tar.xz"))
> +              (sha256
> +               (base32
> +                "1a0d084a98bycyhbw531646rbivvlfkdk6ldshl5dy6fvzmbci0d"))))
> +    (build-system copy-build-system)
> +    (arguments
> +     '(#:install-plan '(("keyrings/pureos-archive-keyring.gpg"
> +                         "share/keyrings/")
> +                        ("keyrings/pureos-archive-removed-keys.gpg"
> +                         "share/keyrings/"))))
> +    (home-page "https://source.puri.sm/pureos/core/pureos-archive-keyring")
> +    (synopsis "GnuPG archive keys of the Pureos archive")
> +    (description "The Pureos distribution signs its packages.  This package
> +contains the archive keys used for that.")
> +    (license (list license:public-domain ;; the keys
> +                   license:gpl2+))))     ;; see debian/copyright
> +
> +(define-public trisquel-keyring
> +  (package
> +    (name "trisquel-keyring")
> +    (version "2022.10.19")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "http://archive.trisquel.info/trisquel/"
> +                    "pool/main/t/trisquel-keyring/trisquel-keyring_"
> +                    version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "1qkqm3wb945i2izm47xni21hi3ad807bvl106r2mnwdxnjs4ij08"))))
> +    (build-system copy-build-system)
> +    (arguments
> +     '(#:install-plan '(("keyrings/trisquel-archive-keyring.gpg"
> +                         "share/keyrings/"))))
> +    (home-page "http://archive.trisquel.info/trisquel/pool/main/t/trisquel-keyring")
> +    (synopsis "GnuPG archive keys of the Trisquel archive")
> +    (description "The Trisquel distribution signs its packages.  This package
> +contains the archive keys used for that.")
> +    (license license:gpl2+)))     ;; see debian/copyright
> +
>  (define-public ubuntu-keyring
>    (package
>      (name "ubuntu-keyring")
> -- 
> 2.41.0
> 
> 
> 
>
Denis 'GNUtoo' Carikli Jan. 23, 2024, 11:49 p.m. UTC | #2
On Fri, 19 Jan 2024 11:38:49 +0200
Efraim Flashner <efraim@flashner.co.il> wrote:

> I'm not against adding both keyrings, but they should be in separate
> commits. 
Indeed. The PureOS keyring is a leftover from a previous version of
this patchset.

I originally added support for PureOS as well but at some point PureOS
changed the way their repository worked so that broke upstream
debootstrap. Here I forgot to remove the keyring package.

> Also, are there scripts to build the keyrings (like debian)
> or are there not really and its just the released keyring file?
Unfortunately Trisquel only provides a keyring file. It's also
available through git here:

https://gitlab.trisquel.org/trisquel/trisquel-packages/-/tree/master/extra/trisquel-keyring?ref_type=heads

I'll send a v2 of the patch set without pureos-keyring.

Denis.
Denis 'GNUtoo' Carikli Jan. 24, 2024, 12:04 a.m. UTC | #3
On Wed, 24 Jan 2024 00:49:33 +0100
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:
> I originally added support for PureOS as well but at some point PureOS
> changed the way their repository worked so that broke upstream
> debootstrap. Here I forgot to remove the keyring package.
I forgot to ask in my previous mail: Is there already an automatic tool
to detect mistakes like that (that I could run before sending patches)?

I have that in the commit message:
> * gnu/packages/debian.scm (trisquel-keyring): New variable.

But the patch shows something different where there is also an
additional package.

Denis.
diff mbox series

Patch

diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index de43182172..4e398f619c 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2018, 2020-2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,6 +25,7 @@  (define-module (gnu packages debian)
   #:use-module (guix git-download)
   #:use-module (guix gexp)
   #:use-module (guix packages)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages autotools)
@@ -146,6 +148,54 @@  (define-public debian-ports-archive-keyring
     ;; "The keys in the keyrings don't fall under any copyright."
     (license license:public-domain)))
 
+(define-public pureos-archive-keyring
+  (package
+    (name "pureos-archive-keyring")
+    (version "2021.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://repo.puri.sm/pureos/pool/main/p/pureos-archive-keyring/"
+                    "pureos-archive-keyring_" version ".tar.xz"))
+              (sha256
+               (base32
+                "1a0d084a98bycyhbw531646rbivvlfkdk6ldshl5dy6fvzmbci0d"))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan '(("keyrings/pureos-archive-keyring.gpg"
+                         "share/keyrings/")
+                        ("keyrings/pureos-archive-removed-keys.gpg"
+                         "share/keyrings/"))))
+    (home-page "https://source.puri.sm/pureos/core/pureos-archive-keyring")
+    (synopsis "GnuPG archive keys of the Pureos archive")
+    (description "The Pureos distribution signs its packages.  This package
+contains the archive keys used for that.")
+    (license (list license:public-domain ;; the keys
+                   license:gpl2+))))     ;; see debian/copyright
+
+(define-public trisquel-keyring
+  (package
+    (name "trisquel-keyring")
+    (version "2022.10.19")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://archive.trisquel.info/trisquel/"
+                    "pool/main/t/trisquel-keyring/trisquel-keyring_"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1qkqm3wb945i2izm47xni21hi3ad807bvl106r2mnwdxnjs4ij08"))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan '(("keyrings/trisquel-archive-keyring.gpg"
+                         "share/keyrings/"))))
+    (home-page "http://archive.trisquel.info/trisquel/pool/main/t/trisquel-keyring")
+    (synopsis "GnuPG archive keys of the Trisquel archive")
+    (description "The Trisquel distribution signs its packages.  This package
+contains the archive keys used for that.")
+    (license license:gpl2+)))     ;; see debian/copyright
+
 (define-public ubuntu-keyring
   (package
     (name "ubuntu-keyring")