diff mbox series

[bug#43438] gnu: Fix fetching the linux-libre deblobbing script.

Message ID 77e65a3b34c2ab70b6f7516595dfa5cd6e6844a1.1600218322.git.leo@famulari.name
State Accepted
Headers show
Series [bug#43438] gnu: Fix fetching the linux-libre deblobbing script. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Leo Famulari Sept. 16, 2020, 1:05 a.m. UTC
This is a followup to commit 105a037090d9a970a2c2336341d6673eff29e4cf.

* gnu/packages/linux.scm (linux-libre-deblob-scripts): Truncate the version in
the file-name, not the source URI.
---
 gnu/packages/linux.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Sept. 16, 2020, 3:23 a.m. UTC | #1
Pushed as cca5720f410ce01e2b3ed7e4fde593e118f08f07
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 59ffb334e0..2e47b81cf6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -195,9 +195,9 @@  defconfig.  Return the appropriate make target if applicable, otherwise return
           (method url-fetch)
           (uri (string-append "https://linux-libre.fsfla.org"
                               "/pub/linux-libre/releases/" version "-gnu/"
-                              "deblob-" version))
+                              "deblob-" (version-major+minor version)))
           (file-name (string-append "linux-libre-deblob-"
-                                    (version-major+minor version)))
+                                    version))
           (sha256 deblob-hash))
         (origin
           (method url-fetch)