diff mbox series

[bug#61651] gnu: gnunet-gtk: Use new style inputs, gexps.

Message ID 77d953d5-d0af-c41e-cffa-bb6acebd243e@disroot.org
State New
Headers show
Series [bug#61651] gnu: gnunet-gtk: Use new style inputs, gexps. | expand

Commit Message

Adam Faiz Feb. 20, 2023, 1:50 p.m. UTC
From 58f04e934a71781f0232fcd20b4e89df39062db9 Mon Sep 17 00:00:00 2001
Message-Id: 
<58f04e934a71781f0232fcd20b4e89df39062db9.1676897203.git.adam.faiz@disroot.org>
In-Reply-To: 
<7bfd653e503e7e8be16179ed1ba2ac15b303c8b7.1676897203.git.adam.faiz@disroot.org>
References: 
<7bfd653e503e7e8be16179ed1ba2ac15b303c8b7.1676897203.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 20 Feb 2023 20:18:23 +0800
Subject: [PATCH] gnu: gnunet-gtk: Use new style inputs, gexps.

* gnu/packages/gnunet.scm (gnunet-gtk): Use new style inputs, gexps.
[arguments]: Use new style and gexps.
[inputs]: Use new style.
---
  gnu/packages/gnunet.scm | 28 ++++++++++++++--------------
  1 file changed, 14 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index fea6c50947..264c876cc4 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -440,21 +440,21 @@  (define-public gnunet-gtk
                 (base32
                  "0z2731l69vnfsa0cdsw8wh8g1d08wz15y5n0a58qjpf7baric01k"))))
      (arguments
-     `(#:configure-flags
-       (list "--with-libunique"
-             "--with-qrencode"
-             (string-append "--with-gnunet="
-                            (assoc-ref %build-inputs "gnunet")))))
+     (list #:configure-flags
+           #~(list "--with-libunique"
+                   "--with-qrencode"
+                   (string-append "--with-gnunet="
+                                  #$(this-package-input "gnunet")))))
      (inputs
-     `(("glade3" ,glade3)
-       ("gnunet" ,gnunet)
-       ("gnutls" ,gnutls/dane)
-       ("gtk+" ,gtk+)
-       ("libextractor" ,libextractor)
-       ("libgcrypt" ,libgcrypt)
-       ("libsodium" ,libsodium)
-       ("libunique" ,libunique)
-       ("qrencode" ,qrencode)))
+     (list glade3
+           gnunet
+           gnutls/dane
+           gtk+
+           libextractor
+           libgcrypt
+           libsodium
+           libunique
+           qrencode))
      (native-inputs
       (list pkg-config libglade))
      (synopsis "Graphical front-end tools for GNUnet")