diff mbox series

[bug#69632] gnu: petsc: add tunable property.

Message ID 77a3ce021227b1bae0217c64791e3c0f456bc9e5.1709891360.git.lars.bilke@ufz.de
State New
Headers show
Series [bug#69632] gnu: petsc: add tunable property. | expand

Commit Message

Lars Bilke March 8, 2024, 9:49 a.m. UTC
Tested with some real-world simulations on multpiple HPC systems.

Change-Id: I81588d0556c4176f29d7ab760322cd7aec271f12
---
 gnu/packages/maths.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)


base-commit: 75bad75367fcf2c289fae3b40dbcc850f92177be

Comments

Efraim Flashner March 12, 2024, 11:54 a.m. UTC | #1
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1f61ee0583..9f0b1ccadc 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3515,7 +3515,8 @@  (define-public petsc
 data structures and routines for the scalable (parallel) solution of
 scientific applications modeled by partial differential equations.")
     (license (license:non-copyleft
-              "https://www.mcs.anl.gov/petsc/documentation/copyright.html"))))
+              "https://www.mcs.anl.gov/petsc/documentation/copyright.html"))
+    (properties '((tunable? . #t)))))
 
 (define-public petsc-complex
   (package