[bug#77952,1/2] gnu: Add python-urllib3-1.25.

Message ID 779681ef6bc55d6789f9417a22dd97435125b721.1745229729.git.csantosb@inventati.org
State New
Headers
Series Fix threadsafety errors in offlineimap with python-3.11. |

Commit Message

Cayetano Santos April 21, 2025, 10:15 a.m. UTC
  * gnu/packages/python-web.scm (python-urllib3-1.25): New variable.

Change-Id: I28ea55b42dee708ad8d15e51d6b8e8a5ec2f392f
---
 gnu/packages/python-web.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8fe9f58978..ef5cd127df 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5139,6 +5139,21 @@  (define-public python-urllib3-next
      (list python-hatchling
            python-hatch-vcs))))
 
+(define-public python-urllib3-1.25
+  (package
+    (inherit python-urllib3)
+    (version "1.25.19")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "urllib3" version))
+       (sha256
+        (base32
+         "09rmjqm5syhhc8fx3v06h3yv6cqy0b1081jg8wm5grpwpr72j61h"))))
+    (native-inputs
+     (list python-setuptools
+           python-wheel))))
+
 (define-public python-urllib3-1.26
   (package
     (inherit python-urllib3)