diff mbox series

[bug#73461,v3] gnu: knot: Update to 3.4.1.

Message ID 7785e56d220a5ae16e6b20496484846ffdb54367.1729415726.git.ashish.is@lostca.se
State New
Headers show
Series [bug#73461,v3] gnu: knot: Update to 3.4.1. | expand

Commit Message

Ashish SHUKLA Oct. 20, 2024, 9:15 a.m. UTC
* gnu/packages/dns.scm (knot): Update to 3.4.1.
[source](patches) Add a patch.
* gnu/packages/patches/knot-remove-runtime-deps.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it here.

Change-Id: I2fcb61a161631954137eaf058bc7c6095fceef47
---
 gnu/local.mk                                  |  1 +
 gnu/packages/dns.scm                          |  6 ++++--
 .../patches/knot-remove-runtime-deps.patch    | 19 +++++++++++++++++++
 3 files changed, 24 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/knot-remove-runtime-deps.patch


base-commit: 551a2b293ee34855f9395b9032e5a8837a64e08e

Comments

Ludovic Courtès Oct. 25, 2024, 10:31 a.m. UTC | #1
Ashish SHUKLA <ashish.is@lostca.se> skribis:

> * gnu/packages/dns.scm (knot): Update to 3.4.1.
> [source](patches) Add a patch.
> * gnu/packages/patches/knot-remove-runtime-deps.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Register it here.
>
> Change-Id: I2fcb61a161631954137eaf058bc7c6095fceef47

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 89a795bfbd..3cec17b52b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1633,6 +1633,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/kiwix-desktop-newer-libkiwix.patch	\
   %D%/packages/patches/kmod-module-directory.patch		\
   %D%/packages/patches/kmscon-runtime-keymap-switch.patch	\
+  %D%/packages/patches/knot-remove-runtime-deps.patch		\
   %D%/packages/patches/kobodeluxe-paths.patch			\
   %D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch	\
   %D%/packages/patches/kobodeluxe-const-charp-conversion.patch	\
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 1e9d1bc904..7f902965d8 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -845,7 +845,7 @@  (define-public yadifa
 (define-public knot
   (package
     (name "knot")
-    (version "3.3.8")
+    (version "3.4.1")
     (source
      (origin
        (method git-fetch)
@@ -854,7 +854,9 @@  (define-public knot
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0iaardlmvcp6f0vccs81f202bb53y7fkcw5n12ahgqymqzhafpmq"))
+        (base32 "0iqzqfjk60lxzbjgkjsf1l8vqnv6rgz1z0p1zyhdqnp037123d4j"))
+       (patches
+        (search-patches "knot-remove-runtime-deps.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin
diff --git a/gnu/packages/patches/knot-remove-runtime-deps.patch b/gnu/packages/patches/knot-remove-runtime-deps.patch
new file mode 100644
index 0000000000..8c5cf21d46
--- /dev/null
+++ b/gnu/packages/patches/knot-remove-runtime-deps.patch
@@ -0,0 +1,19 @@ 
+Following patch is imported from nixpkgs:
+
+source: https://github.com/NixOS/nixpkgs/pull/338995
+
+Remove unnecessary runtime dependencies.
+
+`knotc status configure` shows summary from the configure script,
+but that contains also references like include paths.
+Filter these at least in a crude way (whole lines).
+--- a/configure.ac
++++ b/configure.ac
+@@ -788,5 +788,5 @@ result_msg_base="
+-result_msg_esc=$(echo -n "    Configure:$filtered_config_params\n$result_msg_base" | sed '$!s/$/\\n/' | tr -d '\n')
++result_msg_esc=$(echo -n "    Configure:$filtered_config_params\n$result_msg_base" | grep -Fv "$NIX_STORE" | sed '$!s/$/\\n/' | tr -d '\n')
+ 
+ AC_DEFINE_UNQUOTED([CONFIGURE_SUMMARY],["$result_msg_esc"],[Configure summary])
+ 
+
+