diff mbox series

[bug#66847] gnu: python-baltica: Update to 1.1.2.

Message ID 777b97bec88e9beb56d7d57738eb9aba9956566e.1698760882.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#66847] gnu: python-baltica: Update to 1.1.2. | expand

Commit Message

nafkhamdc Oct. 31, 2023, 2:01 p.m. UTC
* gnu/packages/bioinformatics.scm (python-baltica): Update to 1.1.2.
[propagated-inputs]: Add r-yaml, r-rsamtools, r-biocmanager, r-here, r-genomicranges,
r-readr, r-tidyr, r-stringr, r-optparse, r-openxlsx, r-dplyr, and
r-upsetr.

Change-Id: I8c1bb556048b406b95e081155a46da17a6be5676
---
 gnu/packages/bioinformatics.scm | 76 +++++++++++++++++++--------------
 1 file changed, 43 insertions(+), 33 deletions(-)


base-commit: c0895371c5759c7d9edb330774e90f192cc4cf2c

Comments

Ricardo Wurmus Oct. 31, 2023, 9:05 p.m. UTC | #1
Thanks for the patch.  I changed the commit message and reduced the
number of changes to the essential.

Pushed!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a47e84bc33..66d1a21ffe 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5130,47 +5130,57 @@  (define-public python-baltica
   (package
     (name "python-baltica")
     (version "1.1.2")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/dieterich-lab/Baltica")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "001ac03v9pbqqzf9pv7v8gf0296ksa4f0v3wdmpa6m9701skqi4r"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dieterich-lab/Baltica")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "001ac03v9pbqqzf9pv7v8gf0296ksa4f0v3wdmpa6m9701skqi4r"))))
     (build-system pyproject-build-system)
     (arguments
      (list
-      #:phases
-      '(modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; The tests need to be run from elsewhere...
-               (mkdir-p "/tmp/test")
-               (copy-recursively ".tests" "/tmp/test")
-               (with-directory-excursion "/tmp/test"
-                 (invoke "pytest" "-v" "--doctest-modules"))))))))
-    (propagated-inputs
-     (list gunicorn
-           python-anndata
-           python-click
-           python-flask
-           python-flask-wtf
-           python-h5py
-           python-numpy
-           python-psutil
-           python-pysam
-           python-pyyaml
-           python-scipy
-           snakemake-7))
+      #:phases '(modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        ;; The tests need to be run from elsewhere...
+                        (mkdir-p "/tmp/test")
+                        (copy-recursively ".tests" "/tmp/test")
+                        (with-directory-excursion "/tmp/test"
+                          (invoke "pytest" "-v" "--doctest-modules"))))))))
+    (propagated-inputs (list gunicorn
+                             python-anndata
+                             python-click
+                             python-flask
+                             python-flask-wtf
+                             python-h5py
+                             python-numpy
+                             python-psutil
+                             python-pysam
+                             python-pyyaml
+                             python-scipy
+                             r-yaml
+                             r-rsamtools
+                             r-biocmanager
+                             r-here
+                             r-genomicranges
+                             r-readr
+                             r-tidyr
+                             r-stringr
+                             r-optparse
+                             r-openxlsx
+                             r-dplyr
+                             r-upsetr
+                             snakemake-7))
     (native-inputs (list python-cython python-pyfakefs python-pytest))
     (home-page "https://github.com/dieterich-lab/Baltica")
     (synopsis "Integrated splice junction usage analysis")
     (description
      "This framework facilitates the execution of @dfn{differential junction
-usage} (DJU) methods. Additionally, it enables the integration of results from
+usage} (DJU) methods.  Additionally, it enables the integration of results from
 multiple DJU methods.")
     (license license:expat)))