diff mbox series

[bug#74242,v1] gnu: Add python-vunit.

Message ID 77578fe7778ae147a60340418a4137be19c74e94.1731106487.git.csantosb@inventati.org
State New
Headers show
Series [bug#74242,v1] gnu: Add python-vunit. | expand

Commit Message

Cayetano Santos Nov. 8, 2024, 10:54 p.m. UTC
* gnu/packages/fpga.scm (python-vunit): New variable.

Change-Id: Ieb16ec16928e6b0b2af6992fd9566cb946990dad
---
 gnu/packages/fpga.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index c812ed3b7e..2a0584cc1c 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -433,6 +433,30 @@  (define-public python-myhdl
 a hardware description and verification language.")
     (license license:lgpl2.1+)))
 
+(define-public python-vunit
+  (package
+    (name "python-vunit")
+    (version "4.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/VUnit/vunit")
+             (commit (string-append "v" version))
+             (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0s7j5bykbv34wgnxy5cl4zp6g0caidvzs8pd9yxjq341543xkjwm"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f)) ;requires setuptools_scm >= 2.0.0, <3
+    (propagated-inputs (list python python-colorama))
+    (home-page "https://vunit.github.io")
+    (synopsis "Open source unit testing framework for VHDL/SystemVerilog")
+    (description
+     "VUnit features the functionality needed to realize continuous and automated testing of HDL code.")
+    (license (list license:mpl2.0 license:asl2.0))))
+
 (define-public nvc
   (package
     (name "nvc")