diff mbox series

[bug#56729,RFC,v3,05/32] gnu: Add python-pplpy.

Message ID 77277d80c5af1a555028cc6599319109bd6f0f5b.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/maths.scm (python-pplpy): New variable.
---
 gnu/packages/maths.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1b34c6e314..d92b8528a0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7526,6 +7526,26 @@  (define-public ppl
 functions.")
     (license license:gpl3+)))
 
+(define-public python-pplpy
+  (package
+    (name "python-pplpy")
+    (version "0.8.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pplpy" version))
+              (sha256
+               (base32
+                "1gfq5czkqxl395k06s77zij3xv7maiwagjvzmrpraxhsmvsd02sh"))))
+    (build-system python-build-system)
+    (inputs (list gmp mpc mpfr pari-gp ppl))
+    (native-inputs (list python-cython))
+    (propagated-inputs (list python-cysignals python-gmpy2))
+    (home-page "https://github.com/sagemath/pplpy")
+    (synopsis "Python PPL wrapper")
+    (description
+     "A Python wrapper for @acronym{PPL, the Parma Polyhedra Library}.")
+    (license license:gpl3+)))
+
 (define-public speedcrunch
   (package
     (name "speedcrunch")