diff mbox series

[bug#71647] gnu: Add r-cutpointr.

Message ID 771ef1935d7fa161da2ee81c735ddc8925c0dae2.1718793996.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#71647] gnu: Add r-cutpointr. | expand

Commit Message

Navid Afkhami June 19, 2024, 10:46 a.m. UTC
* gnu/packages/cran.scm (r-cutpointr): New variable.

Change-Id: I60e578fab1e251a526d90ce25dd1c3fc7ec4409d
---
 gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: da1f3aff2ea9a98651ebc69c8385ba136fe2e325

Comments

Andreas Enge June 30, 2024, 8:50 a.m. UTC | #1
Thanks for the patches, I have pushed them after small changes to the
synopsis or description and adding a 2024 copyright line for you.

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 85e0fa98f9..83f395a69e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -704,6 +704,40 @@  (define-public r-curry
 etc.")
     (license license:gpl2+)))
 
+(define-public r-cutpointr
+  (package
+    (name "r-cutpointr")
+    (version "1.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cutpointr" version))
+       (sha256
+        (base32 "1qxnh20hs3bh9v04ls7gwwl7lfc6bwl8c88dn8lkcdqyp3nyr01j"))))
+    (properties `((upstream-name . "cutpointr")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-dplyr
+                             r-foreach
+                             r-ggplot2
+                             r-gridextra
+                             r-purrr
+                             r-rcpp
+                             r-rlang
+                             r-tibble
+                             r-tidyr
+                             r-tidyselect))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/thie1e/cutpointr")
+    (synopsis "Determine and evaluate optimal cutpoints in binary")
+    (description
+     "This package estimates optimal cutpoints for binary classification metrics.
+It also validates performance using bootstrapping.  Some methods for more
+robust cutpoint estimation are supported, e.g. a parametric method assuming
+normal distributions, bootstrapped cutpoints, and smoothing of the metric
+values per cutpoint using Generalized Additive Models.  Various plotting
+functions are included.")
+    (license license:gpl3)))
+
 (define-public r-datawizard
   (package
     (name "r-datawizard")