diff mbox series

[bug#59356,3/5] gnu: Add go-github-com-makeworld-the-better-one-gemget.

Message ID 7701a929-6357-67e8-37c1-2f3221a56c15@disroot.org
State New
Headers show
Series None | expand

Commit Message

Adam Faiz Nov. 18, 2022, 11:53 a.m. UTC
From 55e469d785c75f85898ce2f413ff5e61b89e1354 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 09:15:48 +0800
Subject: [PATCH] gnu: Add
  go-github-com-makeworld-the-better-one-go-gemini.

* gnu/packages/golang.scm 
(go-github-com-makeworld-the-better-one-go-gemini): New variable.
---
  gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
  1 file changed, 26 insertions(+)

      (name "go-github-com-go-git-gcfg")
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c988b50574..97c73abd9f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8009,6 +8009,32 @@  (define-public go-gopkg-in-warnings
  errors (warnings).")
      (license license:bsd-2)))

+(define-public go-github-com-makeworld-the-better-one-go-gemini
+  (package
+    (name "go-github-com-makeworld-the-better-one-go-gemini")
+    (version "0.13.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/makeworld-the-better-one/go-gemini")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0vywbn8sh2spqa35zpk9jkkqaipm915nfb9l1v78pjfman61m6v0"))))
+    (build-system go-build-system)
+    (inputs
+     (list go-github-com-google-go-cmp-cmp
+           go-golang-org-x-net go-golang-org-x-text))
+    (arguments
+     (list #:import-path "github.com/makeworld-the-better-one/go-gemini"))
+    (synopsis "Client library for the Gemini protocol, in Go")
+    (description
+     "go-gemini is a library that provides an easy interface to create 
clients
+that speak the Gemini protocol.")
+    (home-page "https://github.com/makeworld-the-better-one/go-gemini")
+    (license license:isc)))
+
  (define-public go-github-com-go-git-gcfg
    (package