diff mbox series

[bug#40270,2/2] gnu: Add python-flask-session.

Message ID 76eb28742d78ca90279740117b574b31@airmail.cc
State Accepted
Headers show
Series None | expand

Commit Message

pinoaffe Nov. 22, 2020, 7:15 p.m. UTC
* gnu/packages/python-web.scm (python-flask-session, 
python2-flask-session): New variables.
---
  gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
  1 file changed, 25 insertions(+)

+
  (define-public python-html5lib
    (package
      (name "python-html5lib")

Comments

Christopher Baines Nov. 28, 2020, 1:16 p.m. UTC | #1
pinoaffe@airmail.cc writes:

> * gnu/packages/python-web.scm (python-flask-session,
>   python2-flask-session): New variables.
> ---
>  gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index baf24d3849..4ad81ef6e5 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -498,6 +498,31 @@ both of which are installed automatically if you
> install this library.")
>  several extensions for Markdown and integrates into Jinja2 by
>  default.")
>      (license license:bsd-3)))
>
> +(define-public python-flask-session
> +  (package
> +    (name "python-flask-session")
> +    (version "0.3.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "Flask-Session" version))
> +       (sha256
> +        (base32
> +         "0cd7h5c236m6smyixnyfrks4spsqp9d65ndk4p400zr8qgh2f753"))))

0.3.2 has been released, so I updated to that.

> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f)) ;tests require the various storage backends to
> be present
> +    (propagated-inputs
> +     `(("python-flask" ,python-flask)))
> +    (home-page
> +     "https://github.com/fengsp/flask-session")
> +    (synopsis
> +     "Adds server-side session support to your Flask application")
> +    (description
> +     "Adds server-side support for secure sessions to your Flask
> application,
> +and supports a variety of different backends for session storage.")

Similar to python-flask-markdown, I tweaked the description here so it's
less repetitive.

Flask-Session is an extension for Flask that adds support for
Server-side sessions, with a variety of different backends for session
storage.

> +    (license license:bsd-3)))
> +
>  (define-public python-html5lib
>    (package
>      (name "python-html5lib")
Christopher Baines Nov. 28, 2020, 1:17 p.m. UTC | #2
I've pushed these as 9e2669690c80dc00973859edf732964f0a514d7b now, so
closing.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index baf24d3849..4ad81ef6e5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -498,6 +498,31 @@  both of which are installed automatically if you 
install this library.")
  several extensions for Markdown and integrates into Jinja2 by 
default.")
      (license license:bsd-3)))

+(define-public python-flask-session
+  (package
+    (name "python-flask-session")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Flask-Session" version))
+       (sha256
+        (base32
+         "0cd7h5c236m6smyixnyfrks4spsqp9d65ndk4p400zr8qgh2f753"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ;tests require the various storage backends to be 
present
+    (propagated-inputs
+     `(("python-flask" ,python-flask)))
+    (home-page
+     "https://github.com/fengsp/flask-session")
+    (synopsis
+     "Adds server-side session support to your Flask application")
+    (description
+     "Adds server-side support for secure sessions to your Flask 
application,
+and supports a variety of different backends for session storage.")
+    (license license:bsd-3)))