diff mbox series

[bug#55424,v2,3/6] gnu: python-pygame-sdl2: Update to 2.1.0-0-1705c6e.

Message ID 76e01030d3e95b34ed86bf2f9697411f6b7280c8.camel@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

Liliana Marie Prikler June 17, 2022, 8:26 a.m. UTC
* gnu/packages/game-development.scm (python-pygame-sdl2): Update to
2.1.0-0-1705c6e.
---
Hi Maxim (and others reading),

the comment for this one was actually wrong and I adjusted it.
Hopefully it's clearer now why I don't go with "for-renpy-8" in the version.
As for why I can't pick up the correct commit for the nightly build... well,
renpy has it that all of the nightlies reference the renpy commit hash,
including pygame-sdl2.

Cheers

 gnu/packages/game-development.scm | 26 ++++++++++++--------------
 1 file changed, 12 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 099268d58c..f69088324a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1207,26 +1207,24 @@  (define-public python-pygame
                    license:lgpl2.1+))))
 
 (define-public python-pygame-sdl2
+  ;; Using latest git commit as of 2022-06-17, because there is no tagged
+  ;; release for renpy 8.
+  ;; Revert back to URLs once renpy 8 is released!
   (let ((real-version "2.1.0")
-        (renpy-version "7.4.11"))
+        ;;(renpy-version "8.0.0")
+        (commit "1705c6e3004dcb1daf859560bcd52eb093e97d45"))
     (package
       (inherit python-pygame)
       (name "python-pygame-sdl2")
-      (version (string-append real-version "-for-renpy-" renpy-version))
+      (version (git-version real-version "0" commit))
       (source
        (origin
-         (method url-fetch)
-         (uri (string-append "https://www.renpy.org/dl/" renpy-version
-                             "/pygame_sdl2-" version ".tar.gz"))
-         (sha256 (base32 "0nxvca16299jx6sp0ys29rqixcs21ymhqwjfkbchhss0yar7qjgz"))
-         (modules '((guix build utils)))
-         (snippet
-          '(begin
-             ;; drop generated sources
-             (delete-file-recursively "gen")
-             (delete-file-recursively "gen3")
-             (delete-file-recursively "gen-static")
-             #t))))
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/renpy/pygame_sdl2")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256 (base32 "1g0arhpd59zypspk36sgajf1kzavppfkv766vifvxar60968rrjn"))))
       (build-system python-build-system)
       (arguments
        `(#:tests? #f                ; tests require pygame to be installed first