[bug#75088,1/7] gnu: python-babel: Update to 2.16.0.

Message ID 76d8de0b3f80fd05f754a5870ada2724d4accbf6.1735134164.git.sarg@sarg.org.ru
State New
Headers
Series Fix beancount and fava builds. |

Commit Message

Sergey Trofimov Dec. 25, 2024, 2 p.m. UTC
  * gnu/packages/python-xyz.scm (python-babel): Update to 2.16.0.
---
 gnu/packages/python-xyz.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 36e9b38b50..ede99889e5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2962,19 +2962,17 @@  (define-public python-clyent
 (define-public python-babel
   (package
     (name "python-babel")
-    (version "2.10.3")
+    (version "2.16.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Babel" version))
        (sha256
         (base32
-         "0l9cvfmsz0hlvcinxaf6xf2f02ldgw3xq9i1fc7lk5zf24vma53n"))))
+         "05p3k0i5h8v4vqsg36s94kwl4nhgfmgwdq1x7wbzw1b6l965bwyi"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-freezegun python-pytest tzdata-for-tests))
-    (propagated-inputs
-     (list python-pytz))
+     (list python-freezegun python-pytest python-pytest-cov tzdata-for-tests))
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (replace 'check
@@ -15823,7 +15821,7 @@  (define-public python-markdown
 (define-public python-markdown2
   (package
     (name "python-markdown2")
-    (version "2.4.13")
+    (version "2.5.2")
     (source
      (origin
        (method git-fetch) ; no tests data in PyPi package
@@ -15832,7 +15830,7 @@  (define-public python-markdown2
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0m1wy8i4xmna5b97dvks8cfjmc1wid8pxmd2h82869d0ajva3r6a"))))
+        (base32 "01ll612yq7kjmj5p2zi9sf4l2wg6rm1ldcr6h0m2d9j180j7ggs8"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -15844,7 +15842,7 @@  (define-public python-markdown2
                 (with-directory-excursion "test"
                   (invoke "python" "testall.py"))))))))
     (native-inputs
-     (list python-pygments))
+     (list python-setuptools python-pygments))
     (home-page "https://github.com/trentm/python-markdown2")
     (synopsis "Fast and complete Python implementation of Markdown")
     (description