[bug#76895,1/2] gnu: senpai: Install desktop file.

Message ID 76c483d4e73abe4417ae9021ef7e79180746cb22.1741537589.git.lgcoelho@disroot.org
State New
Headers
Series Improve senpai package integration and cleanup |

Commit Message

Luis Guilherme Coelho March 9, 2025, 4:44 p.m. UTC
  * gnu/packages/messaging.scm (senpai)[arguments]<#:phases>: Add
'install-desktop-file phase.

Change-Id: Ib2b84639a3bfa5ff211eda794a99370a1c39061c
---
 gnu/packages/messaging.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d2bc9fcfac..a19673a463 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3722,7 +3722,12 @@  (define-public senpai
                       man1)
                      (install-file
                       (string-append "src/" unpack-path "/doc/senpai.5")
-                      man5)))))))
+                      man5))))
+               (add-after 'install 'install-desktop-file
+                (lambda* (#:key unpack-path #:allow-other-keys)
+                  (install-file
+                    (string-append "src/" unpack-path "/contrib/senpai.desktop")
+                    (string-append #$output "/share/applications")))))))
     (native-inputs
      (list go-git-sr-ht-emersion-go-scfg
            go-github-com-delthas-go-libnp