[bug#77190,30/34] gnu: Add tempo.

Message ID 768c5b241abd90776af2ec3a9d7742b360ce956b.1742668052.git.sharlatanus@gmail.com
State New
Headers
Series Astro update 2025/03. |

Commit Message

Sharlatan Hellseher March 22, 2025, 8:29 p.m. UTC
  * gnu/packages/astronomy.scm (tempo): New variable.

Change-Id: Id2342e6c8879f87c3e6283d8a7e9c657a7472373
---
 gnu/packages/astronomy.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
  

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index df3131646b..de37d6b2e6 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -8168,6 +8168,34 @@  (define-public swarp
 any arbitrary astrometric projection defined in the WCS standard.")
     (license license:gpl3+)))
 
+(define-public tempo
+  (package
+    (name "tempo")
+    (version "13.103")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/tempo/tempo-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1ghml56sd7rhwymrlqlvj3g12hjyqvk2sjl08rqlf5y7dwdp0nvl"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list gfortran))
+    (home-page "https://github.com/nanograv/tempo")
+    (synopsis "Pulsar timing data analysis program")
+    (description
+     "Tempo analyzes pulsar timing data.  Pulse times of arrival (TOAs),
+pulsar model parameters, and coded instructions are read from one or more
+input files.  The TOAs are fitted by a pulse timing model incorporating
+transformation to the solar-system barycenter, pulsar rotation and spin-down
+and, where necessary, one of several binary models.  Program output includes
+parameter values and uncertainties, residual pulse arrival times, chi-squared
+statistics, and the covariance matrix of the model.  In prediction
+mode,ephemerides of pulse phase behavior (in the form of polynomial
+expansions) are calculated from input timing models.")
+    (license license:gpl2+)))
+
 (define-public unsio
   ;; There is no versioned tag, use the latest commit.
   (let ((commit "25e52468298e1194c9726ef5dba9d5fbb46870f5")