diff mbox series

[bug#64925] gnu: renpy: fix image reference paths.

Message ID 768b086d-b386-1eb1-8e73-180daac92da4@gmail.com
State New
Headers show
Series [bug#64925] gnu: renpy: fix image reference paths. | expand

Commit Message

Jesse Gibbons July 29, 2023, 12:42 a.m. UTC
Guix,

The current version of renpy has errors when generating a basic project 
due to a substitution in the `drop-game-from-paths` phase that changes 
too much. Attached is a patch that fixes this problem.

I do not know if there is a related bug report.

Thanks.

Comments

Liliana Marie Prikler July 29, 2023, 2:32 p.m. UTC | #1
Am Freitag, dem 28.07.2023 um 18:42 -0600 schrieb Jesse Gibbons:
> Guix,
> 
> The current version of renpy has errors when generating a basic
> project due to a substitution in the `drop-game-from-paths` phase
> that changes too much. Attached is a patch that fixes this problem.
Could you do a comparison of 'tree' when invoked on a game created with
unpatched renpy vs. patched renpy?

Cheers
Jesse Gibbons July 29, 2023, 4:25 p.m. UTC | #2
I should probably point out that I did my research when producing this 
patch and made not of it in the IRC. I would have removed the 
drop-game-from-paths phase if that didn't result in a similar error to 
the one reported from renpy before the patch is applied to guix.
Liliana Marie Prikler July 30, 2023, 5:56 a.m. UTC | #3
Am Samstag, dem 29.07.2023 um 10:12 -0600 schrieb Jesse Gibbons:
> Is there anything else you want me to do before you accept the patch?
Nope.  I've run some own checks as well, edited the commit message and
pushed it.

Thanks
diff mbox series

Patch

From 60c49e320b6e3411eff834883ea0f733f75d8c2d Mon Sep 17 00:00:00 2001
From: Jesse <jessegibbons@outlook.com>
Date: Fri, 28 Jul 2023 17:50:06 -0600
Subject: [PATCH] gnu: renpy: fix image reference paths.

gnu/packages/game-development.scm: (renpy) fix image reference paths.
---
 gnu/packages/game-development.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 127cbac127..11ecc7e52c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1458,7 +1458,7 @@  (define-public renpy
             (lambda _
               (substitute* (list "launcher/game/gui7.rpy"
                                  "launcher/game/gui7/images.py")
-                ((", \"game\",") ","))
+                ((", \"game\", \"gui7\",") ", \"gui7\","))
               #t))
           (add-before 'build 'start-xserver
             (lambda* (#:key inputs native-inputs #:allow-other-keys)
@@ -3222,3 +3222,4 @@  (define-public bbcsdl
 allowing you to write utilities and games, use sound and graphics, perform
 calculations and create complete applications.")
     (license license:zlib)))
+renpy
-- 
2.41.0