diff mbox series

[bug#50188] gnu: OpenSSL: Update to 1.1.1l [security fixes].

Message ID 7632fa06633b1d0c9cdda55b2e69d556f149ea6d.1629820600.git.leo@famulari.name
State Accepted
Headers show
Series [bug#50188] gnu: OpenSSL: Update to 1.1.1l [security fixes]. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Aug. 24, 2021, 3:56 p.m. UTC
https://www.openssl.org/news/secadv/20210824.txt

* gnu/packages/tls.scm (openssl)[replacement]: Use openssl-1.1.1l.
(openssl-1.1.1k): Replace with ...
(openssl-1.1.1l): ... new variable.
---
 gnu/packages/tls.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

Comments

Leo Famulari Aug. 24, 2021, 8:50 p.m. UTC | #1
An equivalent patch was pushed as 5422920b9eaaa0c6bf779588748595c66ca86ba3
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index fb7d364c94..154b3dc207 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -356,7 +356,7 @@  required structures.")
   (package
    (name "openssl")
    (version "1.1.1j")
-   (replacement openssl-1.1.1k)
+   (replacement openssl-1.1.1l)
    (source (origin
              (method url-fetch)
              (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -490,11 +490,10 @@  required structures.")
    (license license:openssl)
    (home-page "https://www.openssl.org/")))
 
-;; Replacement package to fix CVE-2021-3449 and CVE-2021-3450.
-(define openssl-1.1.1k
+(define openssl-1.1.1l
   (package
     (inherit openssl)
-    (version "1.1.1k")
+    (version "1.1.1l")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -507,7 +506,7 @@  required structures.")
               (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
               (sha256
                (base32
-                "1rdfzcrxy9y38wqdw5942vmdax9hjhgrprzxm42csal7p5shhal9"))))))
+                "1lbblxps2fhmz7bqh058iywh5wxfignbfx1s1kz2fj63b5g3wyhb"))))))
 
 ;; We will not add any new uses of this package. If you add new code that uses
 ;; this package, your change will be reverted!