diff mbox series

[bug#73239,v1,2/2] gnu: xfce: Remove input "xfce4-volumed-pulse"

Message ID 76297635b28eaab58a0ff79ed78747d212495ca0.1726264393.git.ashvithshetty10@gmail.com
State New
Headers show
Series Fix shortcut key issue with xfce4-pulseaudio-plugin | expand

Commit Message

Ashvith Shetty Sept. 13, 2024, 9:59 p.m. UTC
* gnu/packages/xfce.scm (xfce)[inputs]: Remove input "xfce4-volumed-pulse"

Change-Id: I80a80064c75907b2a1e6e880fab9f1e772921b13
---
 gnu/packages/xfce.scm | 89 ++++++++++++++++++++-----------------------
 1 file changed, 42 insertions(+), 47 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 8277668f2c..5ece50b69b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1207,61 +1207,56 @@  (define-public xfce
   (package
     (name "xfce")
     (version (package-version xfce4-session))
-    (source #f)
+    (source
+     #f)
     (build-system trivial-build-system)
     (arguments
      '(#:modules ((guix build union))
-       #:builder
-       (begin
-         (use-modules (ice-9 match)
-                      (guix build union))
-         (match %build-inputs
-           (((names . directories) ...)
-            (union-build (assoc-ref %outputs "out")
-                         directories)
-            #t)))))
-    (inputs
-     (list exo
-           garcon
-           adwaita-icon-theme
-           elementary-xfce-icon-theme
-           greybird-gtk-theme
-           hicolor-icon-theme
-           mate-polkit-for-xfce
-           mousepad
-           ristretto
-           shared-mime-info
-           thunar
-           thunar-volman
-           tumbler
-           xfce4-appfinder
-           xfce4-notifyd                          ;for pop-up notifications
-           xfce4-panel
-           xfce4-power-manager
-           xfce4-screenshooter
-           xfce4-session
-           xfce4-settings
-           xfce4-taskmanager
-           xfce4-terminal
-           xfconf
-           xfdesktop
-           xfwm4
-           xfwm4-themes
-           xkill
-           ;; Panel plugins.
-           xfce4-battery-plugin
-           xfce4-clipman-plugin
-           xfce4-pulseaudio-plugin
-           xfce4-volumed-pulse
-           xfce4-xkb-plugin))
+       #:builder (begin
+                   (use-modules (ice-9 match)
+                                (guix build union))
+                   (match %build-inputs
+                     (((names . directories) ...)
+                      (union-build (assoc-ref %outputs "out") directories) #t)))))
+    (inputs (list exo
+                  garcon
+                  adwaita-icon-theme
+                  elementary-xfce-icon-theme
+                  greybird-gtk-theme
+                  hicolor-icon-theme
+                  mate-polkit-for-xfce
+                  mousepad
+                  ristretto
+                  shared-mime-info
+                  thunar
+                  thunar-volman
+                  tumbler
+                  xfce4-appfinder
+                  xfce4-notifyd ;for pop-up notifications
+                  xfce4-panel
+                  xfce4-power-manager
+                  xfce4-screenshooter
+                  xfce4-session
+                  xfce4-settings
+                  xfce4-taskmanager
+                  xfce4-terminal
+                  xfconf
+                  xfdesktop
+                  xfwm4
+                  xfwm4-themes
+                  xkill
+                  ;; Panel plugins.
+                  xfce4-battery-plugin
+                  xfce4-clipman-plugin
+                  xfce4-pulseaudio-plugin
+                  xfce4-xkb-plugin))
     (propagated-inputs
      ;; Default font that applications such as IceCat require.
      (list font-dejavu))
     (native-search-paths
      ;; For finding panel and thunar plugins.
-     (append
-      (package-native-search-paths xfce4-panel)
-      (package-native-search-paths thunar)))
+     (append (package-native-search-paths xfce4-panel)
+             (package-native-search-paths thunar)))
     (home-page "https://www.xfce.org/")
     (synopsis "Desktop environment (meta-package)")
     (description