diff mbox series

[bug#52478] gnu: Add openorienteering-mapper.

Message ID 75dfa1e0c8f373406534231b4913ff69c24236cf.1639476819.git.sikmir@gmail.com
State Accepted
Headers show
Series [bug#52478] gnu: Add openorienteering-mapper. | expand

Commit Message

Nikolay Korotkiy Dec. 14, 2021, 10:13 a.m. UTC
* gnu/packages/geo.scm (openorienteering-mapper): New variable.
---
 gnu/packages/geo.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

Comments

Nicolas Goaziou Dec. 15, 2021, 3:11 p.m. UTC | #1
Hello,

Nikolay Korotkiy <sikmir@gmail.com> writes:

> * gnu/packages/geo.scm (openorienteering-mapper): New variable.

I re-ordered inputs alphabetically and applied both patches. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 927ddb167d..d2baf04c41 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -61,6 +62,8 @@  (define-module (gnu packages geo)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpp)
+  #:use-module (gnu packages cups)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages datastructures)
@@ -2692,3 +2695,42 @@  (define-public gplates
 reconstructions of geological and paleogeographic features through geological
 time.  Interactively visualize vector, raster and volume data.")
     (license license:gpl2+)))
+
+(define-public openorienteering-mapper
+  (package
+    (name "openorienteering-mapper")
+    (version "0.9.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/OpenOrienteering/mapper")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "11b578h8f3q9yvphbjhqmy2w1cfc9skslzawypqmc3k44v24aj0s"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f
+       #:configure-flags
+       (list
+        "-DLICENSING_PROVIDER:BOOL=OFF"
+        "-DMapper_MANUAL_QTHELP:BOOL=OFF")))
+    (inputs
+     `(("qtbase" ,qtbase-5)
+       ("qtlocation" ,qtlocation)
+       ("qtimageformats" ,qtimageformats)
+       ("qtsensors" ,qtsensors)
+       ("gdal" ,gdal)
+       ("clipper" ,clipper)
+       ("proj" ,proj)
+       ("zlib" ,zlib)
+       ("cups" ,cups)))
+    (native-inputs
+     `(("qttools" ,qttools)
+       ("doxygen" ,doxygen)))
+    (home-page "https://www.openorienteering.org/apps/mapper/")
+    (synopsis "OpenOrienteering Mapper (OOM)")
+    (description "OpenOrienteering Mapper is a software for creating
+maps for the orienteering sport.")
+    (license license:gpl3+)))