diff mbox series

[bug#68086] gnu: f3: Fix cross-compiling.

Message ID 757b3848f79aef293bf52454fb5b10f6a5b0f5a8.1703779139.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#68086] gnu: f3: Fix cross-compiling. | expand

Commit Message

Zheng Junjie Dec. 28, 2023, 3:58 p.m. UTC
* gnu/packages/disk.scm (f3)
[arguments]: Use Gexp.

Change-Id: I906a2b7b7691ae53592cfa35ba64fc7e7d735664
---
 gnu/packages/disk.scm | 25 +++++++++++++------------
 1 file changed, 13 insertions(+), 12 deletions(-)


base-commit: bc509aba838780502b83f7fc3d2aee72903656f2

Comments

Mathieu Othacehe Dec. 29, 2023, 5:09 p.m. UTC | #1
> * gnu/packages/disk.scm (f3)
> [arguments]: Use Gexp.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 754c70897c..165f0a8a74 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
 ;;; Copyright © 2023 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2023 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -843,18 +844,18 @@  (define-public f3
        (base32 "17l5vspfcgfbkqg7bakp3gql29yb05gzawm8n3im30ilzdr53678"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; no check target
-       #:make-flags (list (string-append "CC=" ,(cc-for-target))
-                          (string-append "PREFIX=" %output))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)            ; no configure script
-         (add-after 'build 'build-extra
-           (lambda* (#:key make-flags #:allow-other-keys)
-             (apply invoke "make" "extra" make-flags)))
-         (add-after 'build 'install-extra
-           (lambda* (#:key make-flags #:allow-other-keys)
-             (apply invoke "make" "install-extra" make-flags))))))
+     (list #:tests? #f                      ; no check target
+           #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                                (string-append "PREFIX=" #$output))
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)            ; no configure script
+               (add-after 'build 'build-extra
+                 (lambda* (#:key make-flags #:allow-other-keys)
+                   (apply invoke "make" "extra" make-flags)))
+               (add-after 'build 'install-extra
+                 (lambda* (#:key make-flags #:allow-other-keys)
+                   (apply invoke "make" "install-extra" make-flags))))))
     (inputs
      (list eudev parted))
     (home-page "http://oss.digirati.com.br/f3/")