diff mbox series

[bug#69022,1/5] gnu: bqn: Add singeli.

Message ID 75533bd75ddccc62b5041e1532d6161f074ef93a.1707606060.git.aecepoglu@fastmail.fm
State New
Headers show
Series [bug#69022,1/5] gnu: bqn: Add singeli. | expand

Commit Message

aecepoglu Feb. 10, 2024, 11:01 p.m. UTC
Newer versions of BQN use Singeli

* gnu/packages/bqn.scm: Add singeli

Change-Id: I5a2ce84a2b96cdad0617af46978f44ef1a86047f
---
 gnu/packages/bqn.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: b64862e5cb8209c92aa2eff4cec0be328e38c45d

Comments

Dale Mellor May 3, 2024, 9:22 p.m. UTC | #1
On Sat, 2024-02-10 at 23:01 +0000, aecepoglu wrote:

> Subject: [PATCH 1/5] gnu: bqn: Add singeli.

  If there is only one part to this patch, the "1/5" bit should not be there. 
If there are other parts you need to send them to 69022@debbugs.gnu.org.

> Newer versions of BQN use Singeli
> 
> * gnu/packages/bqn.scm: Add singeli

    Phrase this as: * gnu/packages/bqn.scm: new variable singeli

> 
> Change-Id: I5a2ce84a2b96cdad0617af46978f44ef1a86047f
> ---
>  gnu/packages/bqn.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
> 
> diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
> index 4d03385d21..acac2d45cc 100644
> --- a/gnu/packages/bqn.scm
> +++ b/gnu/packages/bqn.scm
> @@ -34,6 +34,32 @@ (define-module (gnu packages bqn)
>    #:use-module (gnu packages java)
>    #:use-module (gnu packages compression))
>  
> +(define-public singeli
> +  (let ((commit "5f9cbd46c265491ff167a5d9377d1462539dbdd8")

   A few more commits have been made since this one and the date of this patch,
and a couple more have been made since then.  Probably it would be good if you
brought this patch up to date.

   If you have any influence over this, it would be better if upstream made a
versioned release, tagged the repository with the release number, and you use
the tag as the commit to pull.  That would give us a bit more confidence that
this GIT snapshot is appropriate, especially since the project is in a very
early stage of development.

> +        (revision "1"))
> +    (package
> +      (name "singeli")
> +      (version (git-version "0.1.1" revision commit))

   Where does this version number come from?  If it is in the upstream (I
couldn't find it on cursory inspection of the repository), it would be good if
the repository could be tagged with this.

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/mlochbaum/Singeli.git")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "13mfxkb29n4phpqxiwfcd43mcg8773n03nml8d9rhbdb6s5jrixb"))))
> +      (build-system copy-build-system)
> +      (arguments
> +       '(#:install-plan '(("." "lib"))))
> +      (synopsis "Language to generate performant C codes with")

   This is an incomplete sentence.  I might suggest "Compiler for a domain-
specific language called Singeli."

> +      (description
> +       "Singeli is a domain-specific language for building high-performance
> +algorithms with abstractions over code that corresponds to individual
> instructions.
> +It's implemented in BQN, with a frontend that emits IR and a backend that
> converts it to C.")
> +      (home-page "https://github.com/mlochbaum/Singeli")
> +      (license license:isc))))
> +
>  (define-public dbqn
>    (let ((commit "88f2b43966a75cc2c382421218eb30003bb16f4a")
>          (revision "1"))
> 
> base-commit: b64862e5cb8209c92aa2eff4cec0be328e38c45d

Best wishes,
Dale
Dale Mellor May 3, 2024, 9:31 p.m. UTC | #2
Superceded by 69023.
diff mbox series

Patch

diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index 4d03385d21..acac2d45cc 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -34,6 +34,32 @@  (define-module (gnu packages bqn)
   #:use-module (gnu packages java)
   #:use-module (gnu packages compression))
 
+(define-public singeli
+  (let ((commit "5f9cbd46c265491ff167a5d9377d1462539dbdd8")
+        (revision "1"))
+    (package
+      (name "singeli")
+      (version (git-version "0.1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mlochbaum/Singeli.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "13mfxkb29n4phpqxiwfcd43mcg8773n03nml8d9rhbdb6s5jrixb"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan '(("." "lib"))))
+      (synopsis "Language to generate performant C codes with")
+      (description
+       "Singeli is a domain-specific language for building high-performance
+algorithms with abstractions over code that corresponds to individual instructions.
+It's implemented in BQN, with a frontend that emits IR and a backend that converts it to C.")
+      (home-page "https://github.com/mlochbaum/Singeli")
+      (license license:isc))))
+
 (define-public dbqn
   (let ((commit "88f2b43966a75cc2c382421218eb30003bb16f4a")
         (revision "1"))