diff mbox series

[bug#71034,2/2] gnu: cmus: Switch to new package style.

Message ID 74e71f7dc44f42502331ddc349844e75d1fd92cd.1716027969.git.timotej.lazar@araneo.si
State New
Headers show
Series Update cmus | expand

Commit Message

Timotej Lazar May 18, 2024, 10:29 a.m. UTC
* gnu/packages/music.scm (cmus)[arguments]: Use g-exps. Drop trailing #t from
'configure phase.

Change-Id: Ia840202adddf390bd29a0fb57fa1a3294dd7a61a
---
 gnu/packages/music.scm | 20 +++++++++-----------
 1 file changed, 9 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 00f0c3b97f..5c58c95bb5 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -774,17 +774,15 @@  (define-public cmus
                 "1k50z99v2yqshycx6mbk4g5bsaalg5dgzjv3xvwq14abwkw44hli"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; cmus does not include tests
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               ;; It's an idiosyncratic configure script that doesn't
-               ;; understand --prefix=..; it wants prefix=.. instead.
-               (invoke "./configure"
-                       (string-append "prefix=" out))
-               #t))))))
+     (list
+      #:tests? #f ; cmus does not include tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'configure
+            (lambda _
+              ;; It's an idiosyncratic configure script that doesn't
+              ;; understand --prefix=..; it wants prefix=.. instead.
+              (invoke "./configure" (string-append "prefix=" #$output)))))))
     ;; TODO: cmus optionally supports the following formats, which haven't yet
     ;; been added to Guix:
     ;;