diff mbox series

[bug#67077,24/36] gnu: Add rust-tungstenite-0.19.

Message ID 7485f9d98dd457f02164b87b9f65b5dd02d5c6a7.1699716943.git.voroskoi@gmail.com
State New
Headers show
Series [bug#67077,01/36] gnu: rust-cpufeatures-0.2: Update to 0.2.11. | expand

Commit Message

VÖRÖSKŐI András Nov. 11, 2023, 3:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-tungstenite-0.19): New variable.

Change-Id: Ie65bb3ad45991caeda1831bbcdfb07461bcab41e
---
 gnu/packages/crates-io.scm | 46 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c479d97757..e94b9d96f5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -79029,6 +79029,52 @@  (define-public rust-tuikit-0.2
        #:cargo-development-inputs
        (("rust-env-logger" ,rust-env-logger-0.6))))))
 
+(define-public rust-tungstenite-0.19
+  (package
+    (name "rust-tungstenite")
+    (version "0.19.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tungstenite" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0rxzxg4y22rsvdvs4la7igy9117yidc2m6lsfm2hf0xvsska3yqm"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-byteorder" ,rust-byteorder-1)
+        ("rust-bytes" ,rust-bytes-1)
+        ("rust-data-encoding" ,rust-data-encoding-2)
+        ("rust-http" ,rust-http-0.2)
+        ("rust-httparse" ,rust-httparse-1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-native-tls" ,rust-native-tls-0.2)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-rustls" ,rust-rustls-0.21)
+        ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
+        ("rust-sha1" ,rust-sha1-0.10)
+        ("rust-thiserror" ,rust-thiserror-1)
+        ("rust-url" ,rust-url-2)
+        ("rust-utf-8" ,rust-utf-8-0.7)
+        ("rust-webpki" ,rust-webpki-0.22)
+        ("rust-webpki-roots" ,rust-webpki-roots-0.23))
+       #:cargo-development-inputs
+       (("rust-criterion" ,rust-criterion-0.4)
+        ("rust-env-logger" ,rust-env-logger-0.10)
+        ("rust-input-buffer" ,rust-input-buffer-0.5)
+        ("rust-net2" ,rust-net2-0.2)
+        ("rust-rand" ,rust-rand-0.8))))
+    (home-page "https://github.com/snapview/tungstenite-rs")
+    (synopsis "Lightweight stream-based WebSocket implementation")
+    (description
+     "This library provides an implementation of WebSockets, RFC6455. It
+allows for both synchronous (like TcpStream) and asynchronous usage and is
+easy to integrate into any third-party event loops including MIO.  The API
+design abstracts away all the internals of the WebSocket protocol but still
+makes them accessible for those who wants full control over the network.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-tungstenite-0.11
   (package
     (name "rust-tungstenite")