diff mbox series

[bug#38554,v2,1/3] gnu: Add python-fastentrypoints.

Message ID 7481e670a26c27596022171e1e562fb2e0f16dd8.camel@gmail.com
State Accepted
Headers show
Series [bug#38554,v2,1/3] gnu: Add python-fastentrypoints. | expand

Commit Message

Jesse Gibbons Dec. 21, 2019, 5:14 p.m. UTC
* gnu/packages/python-xyz.scm (python-fastentrypoints): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

 ;;;
@@ -16972,3 +16973,28 @@ as @command{which} and @command{find}.  These
commands allow automated
 discovery of what has been installed on an operating system, and where the
 essential tools are located.")
     (license license:bsd-3)))
+
+(define-public python-fastentrypoints
+  (package
+    (name "python-fastentrypoints")
+    (version "0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fastentrypoints" version))
+       (sha256
+        (base32
+         "02s1j8i2dzbpbwgq2a3fiqwm3cnmhii2qzc0k42l0rdxd4a4ya7z"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/ninjaaron/fast-entry_points")
+    (synopsis
+     "Makes entry_points specified in setup.py load more quickly")
+    (description
+     "Using entry_points in your setup.py makes scripts that start really
slowly
+because it imports pkg_resources.  This package allows such setup scripts
to
+load entry points more quickly.")
+    (license license:bsd-3)))
+
+(define-public python2-fastentrypoints
+  (package-with-python2 python-fastentrypoints))
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 520de4607d..9243272dc9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -68,6 +68,7 @@ 
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019 Mădălin Ionel Patrașcu <
madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.