diff mbox series

[bug#55030,v2,31/34] gnu: Add elm-myrho-elm-round.

Message ID 7480f03a36854d5119aaef0f6da617f18d2e20e2.1652890702.git.philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: elm: Update to 0.19.1. Add build system & importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath May 18, 2022, 6:11 p.m. UTC
* gnu/packages/elm.scm (elm-myrho-elm-round): New variable.
---
 gnu/packages/elm.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 45f137dcdc..a4fb99625a 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -686,3 +686,24 @@  (define-public elm-justinmimbs-time-extra
      "This package provides extra functions for working with @code{Posix}
 times from @code{elm/time}.")
     (license license:bsd-3)))
+
+(define-public elm-myrho-elm-round
+  (package
+    (name "elm-myrho-elm-round")
+    (version "1.0.4")
+    (source
+     (elm-package-origin
+      "myrho/elm-round"
+      version
+      (base32 "0y3j43wr815cvwz5310zalnqzpg3hw8h127zjjlf6x8ynapc2mdb")))
+    (build-system elm-build-system)
+    (propagated-inputs (list elm-core))
+    (inputs (list elm-explorations-test))
+    (home-page "https://package.elm-lang.org/packages/myrho/elm-round/1.0.4")
+    (synopsis "Flexible rounding of Elm @code{Float}s")
+    (description
+     "This library converts a @code{Float} to a @code{String} with ultimate
+control how many digits after the decimal point are shown and how the
+remaining digits are rounded.  It rounds, floors and ceils the @dfn{common}
+way (i.e. half up) or the @dfn{commerical} way (ie. half away from zero).")
+    (license license:bsd-3)))