diff mbox series

[bug#70896] gnu: Add wordwarvi.

Message ID 743c0780eb2d5d2a6d04d86c2b4600f0cfa25171.1715526406.git.GNUtoo@cyberdimension.org
State New
Headers show
Series [bug#70896] gnu: Add wordwarvi. | expand

Commit Message

Denis 'GNUtoo' Carikli May 12, 2024, 3:08 p.m. UTC
* gnu/packages/games.scm (wordwarvi): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Change-Id: I2f48c12b780943c56e4d191d43fec3f247261607
---
 gnu/packages/games.scm | 58 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)


base-commit: 56980ea500a1db3c8586972b8abfaf5c4e24f82d

Comments

Nicolas Graves May 15, 2024, 7:17 a.m. UTC | #1
The order of package fields is a bit odd, but otherwise LGTM. Built and
rebuilt deterministically. No lints.

On 2024-05-12 17:08, Denis 'GNUtoo' Carikli wrote:

> * gnu/packages/games.scm (wordwarvi): New variable.
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
> Change-Id: I2f48c12b780943c56e4d191d43fec3f247261607
> ---
>  gnu/packages/games.scm | 58 ++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 58 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index d7b79907b0..23a6e0cbd2 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -4710,6 +4710,64 @@ (define-public wesnoth-server
>      (description "This package contains a dedicated server for @emph{The
>  Battle for Wesnoth}.")))
>  
> +(define-public wordwarvi
> +  (package
> +    (name "wordwarvi")
> +    (version "1.0.4")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/smcameron/wordwarvi")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0f9xhm7267g27f2k1v4dylzvrfyhr9y60f5ypq5a5kiqrqykm245"))))
> +    (build-system gnu-build-system)
> +    (inputs (list alsa-lib gtk+-2 libvorbis portaudio))
> +    (native-inputs (list pkg-config))
> +    (arguments
> +     (list
> +      #:make-flags #~(list "BINDIR=/bin"
> +                           (string-append "CC="
> +                                          #$(cc-for-target))
> +                           (string-append "DATADIR="
> +                                          #$output "")
> +                           (string-append "DESTDIR="
> +                                          #$output) "PREFIX=")
> +      #:tests? #f ;no tests
> +      #:phases #~(modify-phases %standard-phases
> +                   (delete 'configure)
> +                   (add-after 'unpack 'fix-makefile
> +                     (lambda _
> +                       (substitute* "Makefile"
> +                         (("/bin/rm")
> +                          "rm")
> +                         (("-DDATADIR=\\\\\"\\$\\{DATADIR\\}/\\\\\"")
> +                          "-DDATADIR=\\\"${DESTDIR}/${DATADIR}/\\\"")))))))
> +    (synopsis "Arcade-style side scrolling space shooter")
> +    (description
> +     "In this game you pilot a combat space ship to rescue your lost
> +\"vi\" .swp files avoiding OS defenses (missiles, other combat space
> +ships, etc).  It contains several levels and the difficulty level is
> +configurable on the command line.  It can be played with a
> +keyboard (with standard arrow keys, or vi key bindings(hjkl)) or a
> +joystick.  It is drawn mostly with lines, and support various display
> +modes (color, black and white, etc).")
> +    ;; For the code, most files are under GPLv2+, but since the ogg_to_pcm.c
> +    ;; file is GPLv2 without 'any later version', we use 'gpl2' because of the
> +    ;; ambiguity. For the sounds the licenses are declared in
> +    ;; sounds/Attribution.txt and for aaaah_it_burns.ogg, it can be viewed with
> +    ;; vorbiscomment -l.
> +    (license (list license:gpl2 ;For the code
> +                   ;; lucky-holiday-cornbread-stuffing-mono.ogg
> +                   ;; lucky13-steve-mono-mix.ogg
> +                   ;; aaaah_it_burns.ogg
> +                   license:cc-by3.0
> +                   ;; all other sounds are under cc-by-sa 3.0
> +                   license:cc-by-sa3.0))
> +    (home-page "https://smcameron.github.io/wordwarvi/")))
> +
>  (define-public gamine
>    (package
>      (name "gamine")
>
> base-commit: 56980ea500a1db3c8586972b8abfaf5c4e24f82d
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d7b79907b0..23a6e0cbd2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4710,6 +4710,64 @@  (define-public wesnoth-server
     (description "This package contains a dedicated server for @emph{The
 Battle for Wesnoth}.")))
 
+(define-public wordwarvi
+  (package
+    (name "wordwarvi")
+    (version "1.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/smcameron/wordwarvi")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0f9xhm7267g27f2k1v4dylzvrfyhr9y60f5ypq5a5kiqrqykm245"))))
+    (build-system gnu-build-system)
+    (inputs (list alsa-lib gtk+-2 libvorbis portaudio))
+    (native-inputs (list pkg-config))
+    (arguments
+     (list
+      #:make-flags #~(list "BINDIR=/bin"
+                           (string-append "CC="
+                                          #$(cc-for-target))
+                           (string-append "DATADIR="
+                                          #$output "")
+                           (string-append "DESTDIR="
+                                          #$output) "PREFIX=")
+      #:tests? #f ;no tests
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'configure)
+                   (add-after 'unpack 'fix-makefile
+                     (lambda _
+                       (substitute* "Makefile"
+                         (("/bin/rm")
+                          "rm")
+                         (("-DDATADIR=\\\\\"\\$\\{DATADIR\\}/\\\\\"")
+                          "-DDATADIR=\\\"${DESTDIR}/${DATADIR}/\\\"")))))))
+    (synopsis "Arcade-style side scrolling space shooter")
+    (description
+     "In this game you pilot a combat space ship to rescue your lost
+\"vi\" .swp files avoiding OS defenses (missiles, other combat space
+ships, etc).  It contains several levels and the difficulty level is
+configurable on the command line.  It can be played with a
+keyboard (with standard arrow keys, or vi key bindings(hjkl)) or a
+joystick.  It is drawn mostly with lines, and support various display
+modes (color, black and white, etc).")
+    ;; For the code, most files are under GPLv2+, but since the ogg_to_pcm.c
+    ;; file is GPLv2 without 'any later version', we use 'gpl2' because of the
+    ;; ambiguity. For the sounds the licenses are declared in
+    ;; sounds/Attribution.txt and for aaaah_it_burns.ogg, it can be viewed with
+    ;; vorbiscomment -l.
+    (license (list license:gpl2 ;For the code
+                   ;; lucky-holiday-cornbread-stuffing-mono.ogg
+                   ;; lucky13-steve-mono-mix.ogg
+                   ;; aaaah_it_burns.ogg
+                   license:cc-by3.0
+                   ;; all other sounds are under cc-by-sa 3.0
+                   license:cc-by-sa3.0))
+    (home-page "https://smcameron.github.io/wordwarvi/")))
+
 (define-public gamine
   (package
     (name "gamine")