diff mbox series

[bug#49123,02/24] gnu: libolm: Add python bindings output.

Message ID 740edb0fd9d4c549c3d0d9b5d033a29a601a3a78.camel@disroot.org
State New
Headers show
Series None | expand

Commit Message

slg July 4, 2021, 2:41 p.m. UTC
Hi,

Sorry for late reply, thanks for your report.

On Mon, 2021-06-21 at 17:44 +0200, Maxime Devos wrote:
> >           (replace 'check
> >             (lambda* (#:key tests? #:allow-other-keys)
> >               (with-directory-excursion "tests"
> >                 (when tests?
> > -                 (invoke "ctest" ".")
> > +                 (invoke "ctest" ".")))))
> 
> That way, "guix build libolm --without-tests=libolm" should work.

I hope my changes are fine.

Sincerely,

slg
diff mbox series

Patch

From 432af0b078cb2cf5b7a2dce54180b0685ed3988c Mon Sep 17 00:00:00 2001
From: vslg <slgf@protonmail.ch>
Date: Sun, 4 Jul 2021 11:31:37 -0300
Subject: [PATCH] gnu: libolm: Make tests conditional

* gnu/packages/crypto.scm (libolm): Make tests conditional
---
 gnu/packages/crypto.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index c28b563651..13dea466a8 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1319,9 +1319,10 @@  Trusted comments are signed, thus verified, before being displayed.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
+           (lambda* (#:key tests? #:allow-other-keys)
              (with-directory-excursion "tests"
-               (invoke "ctest" "."))))
+               (when tests?
+                 (invoke "ctest" ".")))))
          (add-after 'install 'install-python-binding
            (lambda* (#:key outputs #:allow-other-keys)
              (with-directory-excursion "../source/python"
-- 
2.32.0