From 2540268b519156c1bf235d507f5d80adf2f81eb6 Mon Sep 17 00:00:00 2001
From: Brice Waegeneire <brice@waegenei.re>
Date: Sun, 16 Jan 2022 10:58:20 +0100
Subject: [PATCH 1/3] gnu: deluge: Update to 2.0.5.
* gnu/packages/bittorrent.scm (deluge): Update to 2.0.5.
[arguments]: Remove 'fix-gettext-warning' phase.
---
gnu/packages/bittorrent.scm | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)
@@ -14,6 +14,7 @@
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
+;;; Copyright © 2022 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -521,7 +522,7 @@ (define-public qbittorrent
(define-public deluge
(package
(name "deluge")
- (version "2.0.3")
+ (version "2.0.5")
(source
(origin
(method url-fetch)
@@ -530,7 +531,7 @@ (define-public deluge
(version-major+minor version) "/deluge-" version ".tar.xz"))
(sha256
(base32
- "14d8kn2pvr1qv8mwqrxmj85jycr73vwfqz12hzag0ararbkfhyky"))))
+ "1n15dzfnz1gvb4cf046yhi404i3gs933qgz0ichna6r1znmh9gf4"))))
(build-system python-build-system)
(propagated-inputs
`(("gtk+" ,gtk+)
@@ -562,13 +563,6 @@ (define-public deluge
`(#:tests? #f
#:phases
(modify-phases %standard-phases
- ;; Remove this phase when upgrading to version 2.0.4 or beyond, as
- ;; the issue is fixed upstream.
- (add-after 'unpack 'fix-gettext-warning
- (lambda _
- (substitute* "deluge/i18n/util.py"
- (("names='ngettext'") "names=['ngettext']"))
- #t))
(add-after 'install 'wrap
(lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
--
2.34.0