diff mbox series

[bug#63974] gnu: Add python-mofax.

Message ID 7399348a0fb8ebcda6b7d99b91e20fadae73a5c1.1686319557.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#63974] gnu: Add python-mofax. | expand

Commit Message

nafkhamdc June 9, 2023, 2:05 p.m. UTC
* gnu/packages/bioinformatics.scm (python-mofax): New variable.
---
 gnu/packages/bioinformatics.scm | 40 +++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)


base-commit: e8f9fb3e03ea8fee0e13f13706a6b16414f74a7b

Comments

Ricardo Wurmus June 9, 2023, 3:10 p.m. UTC | #1
Pushed with minor changes.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9ce28596c2..1caea80f86 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3312,6 +3312,46 @@  (define-public python-bx-python
 multiple sequence alignments.")
     (license license:expat)))
 
+(define-public python-mofax
+  (let ((commit "4d96f8f0a5d5251847353656f523684d66c3c47a")
+        (revision "0"))
+    (package
+      (name "python-mofax")
+      (version (git-version "0.4.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/bioFAM/mofax")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1lwrw0qyvvnyiqz1l20dhcf7dxidb80cqgvk78czvdgba87yxzqx"))
+                (modules '((guix build utils)))
+                (snippet '(substitute* "pyproject.toml"
+                            (("^#.*")
+                             "")))))
+      (build-system pyproject-build-system)
+      (arguments
+       (list
+        ;; This test is failing due to a bug. The bug has been reported to the developers. See https://github.com/bioFAM/mofax/issues/12 for more info.
+        #:test-flags '(list "-k" "not test_get_methods")))
+      (propagated-inputs (list python-h5py
+                               python-matplotlib
+                               python-pandas
+                               python-poetry-core
+                               python-scipy
+                               python-seaborn))
+      (native-inputs (list python-numpy python-pytest))
+      (home-page "https://github.com/bioFAM/mofax")
+      (synopsis
+       "Motif activity finder for transcription factor motif analysis")
+      (description
+       "MoFax is a Python package for transcription factor motif analysis.
+It provides convenience functions to load and visualize factor
+models trained with MOFA+ in Python.")
+      (license license:expat))))
+
 (define-public python-pyega3
   (package
     (name "python-pyega3")