diff mbox series

[bug#38126] gnu: Add libltc.

Message ID 7396e826a5e7f7de0ccefe67068f540d@posteo.net
State Accepted
Headers show
Series [bug#38126] gnu: Add libltc. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 10:47 a.m. UTC
From 061201b2179f5ac1c0a3cce89a256d7722c31978 Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:45:11 +0000
Subject: [PATCH] gnu: Add libltc.

* gnu/packages/audio.scm: (libltc): New variable.
---
  gnu/packages/audio.scm | 28 ++++++++++++++++++++++++++++
  1 file changed, 28 insertions(+)

+Time Code (LTC).")
+    (home-page "http://x42.github.io/libltc/")
+    (license license:lgpl3+)))

Comments

Marius Bakke Nov. 10, 2019, 10:05 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

>  From 061201b2179f5ac1c0a3cce89a256d7722c31978 Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:45:11 +0000
> Subject: [PATCH] gnu: Add libltc.
>
> * gnu/packages/audio.scm: (libltc): New variable.

[...]

> +(define-public libltc
> +  (package
> +    (name "libltc")
> +    (version "1.3.1")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append
> +               "https://github.com/x42/libltc/releases/download/v"
> +               version "/libltc-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "173h9dgmain3nyrwk6q2d7yl4fnh4vacag4s2p01n5b7nyrkxrjh"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f)) ; tests fail

Could you give some information as to why the tests fail?  Often it's
simply because of '/bin/sh' references and similar.  You can investigate
a failed build with 'guix build --keep-failed'.

> +    (inputs
> +     `(("glibc" ,glibc)))

glibc is always available and does not need to be explicitly provided.

> +    (native-inputs
> +     `(("doxygen" ,doxygen)
> +       ("pkg-config" ,pkg-config)))
> +    (synopsis "Linear/Logitudinal Time Code (LTC) Library")
> +    (description "Libltc is a POSIX-C Library for handling 
> Linear/Logitudinal
> +Time Code (LTC).")
> +    (home-page "http://x42.github.io/libltc/")
                     ^^^
                   HTTPS
> +    (license license:lgpl3+)))
> -- 
> 2.24.0
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 28dbf06f3b..acfd517bee 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@ 
  ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
  ;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
  ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -3773,3 +3774,30 @@  other Gnaural instances, allowing synchronous 
sessions between many users.")
  a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the 
audio
  stream to one or more IceCast and/or ShoutCast servers.")
      (license license:gpl3+)))
+
+(define-public libltc
+  (package
+    (name "libltc")
+    (version "1.3.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://github.com/x42/libltc/releases/download/v"
+               version "/libltc-" version ".tar.gz"))
+        (sha256
+          (base32
+            "173h9dgmain3nyrwk6q2d7yl4fnh4vacag4s2p01n5b7nyrkxrjh"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f)) ; tests fail
+    (inputs
+     `(("glibc" ,glibc)))
+    (native-inputs
+     `(("doxygen" ,doxygen)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Linear/Logitudinal Time Code (LTC) Library")
+    (description "Libltc is a POSIX-C Library for handling 
Linear/Logitudinal