[bug#35115] gnu: rust: Update to 1.33.0

Message ID 7396117A-02C0-48D4-A643-56519ED8E608@gmail.com
State Accepted
Headers show
Series [bug#35115] gnu: rust: Update to 1.33.0 | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ivan Petkov April 3, 2019, 2:33 a.m. UTC
* gnu/packages/rust.scm (rust): Rename to...
(rust-1.32): ...this.
(rust): New variable.
---
 gnu/packages/rust.scm | 27 ++++++++++++++++++++++++++-
 1 file changed, 26 insertions(+), 1 deletion(-)

Comments

Ivan Petkov April 3, 2019, 5:17 a.m. UTC | #1
Realized I forgot to rename the `rust-1.33` variable to `rust` when
I sent out the patch, but something that should be tweaked before pushing…

—Ivan
Ludovic Courtès April 11, 2019, 10:54 a.m. UTC | #2
Hi Ivan,

Ivan Petkov <ivanppetkov@gmail.com> skribis:

> * gnu/packages/rust.scm (rust): Rename to...
> (rust-1.32): ...this.
> (rust): New variable.

I added the new ‘rust’ variable and applied.

Thank you!

Ludo’.

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 63426a12fc..fb045afad4 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -928,7 +928,7 @@  jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                    (("```rust") "```rust,no_run"))
                  #t)))))))))
 
-(define-public rust
+(define-public rust-1.32
   (let ((base-rust
          (rust-bootstrapped-package rust-1.31 "1.32.0"
           "0ji2l9xv53y27xy72qagggvq47gayr5lcv2jwvmfirx029vlqnac"
@@ -980,3 +980,28 @@  jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
              ;; Remove no longer relevant steps
              (delete 'remove-flaky-test)
              (delete 'patch-aarch64-test))))))))
+
+(define-public rust-1.33
+  (let ((base-rust
+         (rust-bootstrapped-package rust-1.32 "1.33.0"
+                                    "152x91mg7bz4ygligwjb05fgm1blwy2i70s2j03zc9jiwvbsh0as"
+                                    #:patches '())))
+    (package
+      (inherit base-rust)
+      (inputs
+       ;; Upgrade to jemalloc@5.1.0
+       (alist-replace "jemalloc" (list jemalloc)
+                      (package-inputs base-rust)))
+      (arguments
+       (substitute-keyword-arguments (package-arguments base-rust)
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (delete 'ignore-cargo-package-tests)
+             (add-after 'configure 'configure-test-threads
+               ;; Several rustc and cargo tests will fail if run on one core
+               ;; https://github.com/rust-lang/rust/issues/59122
+               ;; https://github.com/rust-lang/cargo/issues/6746
+               ;; https://github.com/rust-lang/rust/issues/58907
+               (lambda* (#:key inputs #:allow-other-keys)
+                 (setenv "RUST_TEST_THREADS" "2")
+                 #t)))))))))